Upstream-status: Taken from: . See . commit 11ad033e1c09c8b8e7bbaa72420f41ab8bcf0f63 Author: Flavio Cruz Date: Tue Jul 30 00:51:20 2024 -0400 x86_64 hurd: ensure we have a large enough buffer to receive exception_raise requests. Message-ID: diff --git a/hurd/hurdfault.c b/hurd/hurdfault.c index 5110c6030f..1fe973f54d 100644 --- a/hurd/hurdfault.c +++ b/hurd/hurdfault.c @@ -121,7 +121,14 @@ faulted (void) struct { mach_msg_header_t head; - char buf[64]; + /* This is the size of the exception_raise request + * including mach_msg_header_t. + * See generated code in faultexc_server.c. */ +#ifdef __LP64__ + char buf[112]; +#else + char buf[64]; +#endif } request; mig_reply_header_t reply; extern int _hurdsig_fault_exc_server (mach_msg_header_t *, mmaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2021-10-26syscalls: Add 'openpty' and 'login-tty'.Ludovic Courtès
* guix/build/syscalls.scm (openpty, login-pty): New procedures. * tests/syscalls.scm ("openpty", "openpty + login-tty"): New tests.
2021-02-25syscalls: Add 'mounts' and the <mount> record type.Ludovic Courtès
* guix/build/syscalls.scm (<mount>): New record type. (option-string->mount-flags, mount-flags) (octal-decode, mounts): New procedures. (mount-points): Rewrite in terms of 'mount'. * tests/syscalls.scm ("mounts"): New test.
2020-06-28tests: Do not fail when network interface aliases are present.Marius Bakke
Fixes <https://bugs.gnu.org/42111>. * tests/syscalls.scm ("network-interface-names"): Filter interface names with a colon.
2020-06-05tests: syscall: Support file-systems without extended attributes.Mathieu Othacehe
* tests/syscalls.scm (setxattr): Catch ENOTSUP that can be raised if the file-system does not support extended user attributes.
2020-06-02tests: Allow passing on systems without support for swap devices.Simon South
* tests/syscalls.scm ("swapon", "swapoff"): Accept ENOSYS as a valid result. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
2020-05-14syscalls: Add 'getxattr'.Jan (janneke) Nieuwenhuizen
* guix/build/syscalls.scm (getxattr): New procedure. * tests/syscalls.scm ("getxattr, setxattr"): Test it, together with setxattr.
2020-02-11syscalls: Re-enable 'pivot-root' test.Ludovic Courtès
Fixes <https://bugs.gnu.org/25476>. Reported by Paul Garlick <pgarlick@tourbillion-technology.com>. * tests/syscalls.scm ("pivot-root"): Skip only when PERFORM-CONTAINER-TESTS? is true. Rewrite to use a socket pair instead of a pipe. Synchronize parent and child so that the parent can initialize the child's UID and GID mappings before continuing.