Fix a regression in glibc 2.27 when built without ldconfig. See for details. diff --git a/include/libc-symbols.h b/include/libc-symbols.h index 6137304b0b..7d630f36d8 100644 --- a/include/libc-symbols.h +++ b/include/libc-symbols.h @@ -508,7 +508,7 @@ for linking") # ifndef __ASSEMBLER__ # if !defined SHARED && IS_IN (libc) && !defined LIBC_NONSHARED \ && (!defined PIC || !defined NO_HIDDEN_EXTERN_FUNC_IN_PIE) \ - && !defined NO_HIDDEN + && !defined NO_HIDDEN && defined USE_LDCONFIG # define __hidden_proto_hiddenattr(attrs...) \ __attribute__ ((visibility ("hidden"), ##attrs)) # define hidden_proto(name, attrs...) \ '/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/herd.scm
AgeCommit message (Collapse)Author
2023-07-21services: herd: Add a new 'current-service' procedure.Maxim Cournoyer
* gnu/services/herd.scm (current-service): New procedure, mostly reusing the existing current-services. (current-services): Implement in terms of the above procedure.
2023-05-30services: herd: "Resolve" transient services only when needed.Ludovic Courtès
This allows us to get rid of the "eval root" actions, which in turn would lead to confusing "Evaluating user expression" messages. Fixes <https://issues.guix.gnu.org/55857>. * gnu/services/herd.scm (resolve-transients): In 'values', avoid 'eval-there' call when UNRESOLVED is empty.
2023-04-21services: herd: 'load-services/safe' is synonymous with 'load-services'.Ludovic Courtès
This is a followup to 547965aa27b6a09cadf42130b7ec7db3f1aee61f. * gnu/services/herd.scm (load-services/safe): Make an alias for 'load-services'.
2023-03-26services: herd: Remove workaround for Shepherd < 0.5.0.Ludovic Courtès
* gnu/services/herd.scm (load-services/safe): Remove workaround for Shepherd < 0.5.0, released in 2018.