We want to allow builds in chroots that lack /bin/sh. Thus, system(3)
and popen(3) need to be tweaked to use the right shell. For the bootstrap
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
instead uses the hard-coded absolute file name of `bash'.
In addition, status should be initialized to 0 and not -1.
diff --git a/libio/iopopen.c b/libio/iopopen.c
index ebc381ed7c..e0d3ed1bc3 100644
--- a/libio/iopopen.c
+++ b/libio/iopopen.c
@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
return false;
}
- if (__posix_spawn (&((_IO_proc_file *) fp)->pid, _PATH_BSHELL, fa, 0,
+ if (__posix_spawnp (&((_IO_proc_file *) fp)->pid, "sh", fa, 0,
(char *const[]){ (char*) "sh", (char*) "-c",
(char *) command, NULL }, __environ) != 0)
return false;
diff --git a/sysdeps/posix/system.c b/sysdeps/posix/system.c
index a03f478fc7..94da6facf3 100644
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
@@ -101,7 +101,7 @@ cancel_handler (void *arg)
static int
do_system (const char *line)
{
- int status = -1;
+ int status = 0;
int ret;
pid_t pid;
struct sigaction sa;
@@ -145,7 +145,7 @@ do_system (const char *line)
__posix_spawnattr_setflags (&spawn_attr,
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
- ret = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
+ ret = __posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
(char *const[]){ (char *) SHELL_NAME,
(char *) "-c",
(char *) line, NULL },
--- a/include/spawn.h
+++ b/include/spawn.h
@@ -5,6 +5,9 @@
__typeof (posix_spawn) __posix_spawn;
libc_hidden_proto (__posix_spawn)
+__typeof (posix_spawnp) __posix_spawnp;
+libc_hidden_proto (__posix_spawnp)
+
__typeof (posix_spawn_file_actions_addclose)
__posix_spawn_file_actions_addclose attribute_hidden;
--- a/posix/spawnp.c
+++ b/posix/spawnp.c
@@ -31,6 +31,7 @@ __posix_spawnp (pid_t *pid, const char *file,
SPAWN_XFLAGS_USE_PATH);
}
versioned_symbol (libc, __posix_spawnp, posix_spawnp, GLIBC_2_15);
+libc_hidden_def (__posix_spawnp)
#if SHLIB_COMPAT (libc, GLIBC_2_2, GLIBC_2_15)
a300b'>gnu/packages/orange.scm
Age | Commit message (Expand) | Author |
2023-04-19 | gnu: python-typing-extensions: Move to (gnu packages python-build)....* gnu/packages/python-xyz.scm (python-typing-extensions): Move to...
* gnu/packages/python-build.scm (python-typing-extensions): ... here.
| Maxim Cournoyer |
2023-02-17 | gnu: Make nothing depend on QtWebKit....This is required for <https://issues.guix.gnu.org/53289>.
* gnu/packages/qt.scm (python-pyqt)[inputs]: Remove qtwebkit.
(python-pyqt-without-qtwebkit): Remove variable.
(python-pyqtwebengine)[inputs]: Replace python-pyqt-without-qtwebkit with
python-pyqt.
* gnu/packages/backup.scm (vorta)[inputs]: Likewise.
* gnu/packages/ebook.scm (calibre)[inputs]: Likewise.
[arguments]: Adjust accordingly.
* gnu/packages/education.scm (anki)[inputs]: Replace
python-pyqt-without-qtwebkit with python-pyqt.
* gnu/packages/kde-games.scm (kajongg)[inputs]: Likewise.
* gnu/packages/maths.scm (veusz)[inputs]: Likewise.
* gnu/packages/music.scm (frescobaldi)[inputs]: Likewise.
(picard)[inputs]: Likewise.
* gnu/packages/orange.scm (orange)[inputs]: Likewise.
* gnu/packages/pdf.scm (flyer-composer)[inputs]: Likewise.
* gnu/packages/python-check.scm (python-pytest-qt)[propagated-inputs]: Likewise.
* gnu/packages/python-xyz.scm (python-qtconsole)[propagated-inputs]: Likewise.
(python-pyqtgraph)[propagated-inputs]: Likewise.
* gnu/packages/radio.scm (gnuradio)[inputs]: Likewise.
* gnu/packages/video.scm (openshot)[inputs]: Likewise.
* gnu/packages/vpn.scm (openconnect-sso)[inputs]: Likewise.
* gnu/packages/web-browsers.scm (qutebrowser)[inputs]: Likewise.
| Leo Famulari |
2022-09-06 | gnu: orange: Fix QT_PLUGIN_PATH....* gnu/packages/orange.scm (orange)[arguments]: Fix QT_PLUGIN_PATH.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Greg Hogan |
2022-07-31 | gnu: qtsvg: Rename variable to qtsvg-5....This is in preparation of the qtsvg update to version 6.
This change was automated via the following command:
git grep -l '\bqtsvg\b' | xargs sed 's/qtsvg/qtsvg-5/g' -i
| Maxim Cournoyer |
2022-06-18 | gnu: orange: Update to 3.32.0....* gnu/packages/orange.scm (orange): Update to 3.32.0.
| Vinicius Monego |