We want to allow builds in chroots that lack /bin/sh. Thus, system(3) and popen(3) need to be tweaked to use the right shell. For the bootstrap glibc, we just use whatever `sh' can be found in $PATH. The final glibc instead uses the hard-coded absolute file name of `bash'. --- a/sysdeps/posix/system.c +++ b/sysdeps/posix/system.c @@ -106,8 +106,8 @@ do_system (const char *line) (void) UNBLOCK; /* Exec the shell. */ - (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ); + (void) execvp (SHELL_NAME, (char *const *) new_argv); _exit (127); } else if (pid < (pid_t) 0) /* The fork failed. */ --- a/libio/iopopen.c +++ b/libio/iopopen.c @@ -170,7 +170,7 @@ _IO_new_proc_open (fp, command, mode) for (p = proc_file_chain; p; p = p->next) _IO_close (_IO_fileno ((_IO_FILE *) p)); - _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0); + execlp ("sh", "sh", "-c", command, (char *) 0); _IO__exit (127); } _IO_close (child_end); class='tabs'> aboutsummaryrefslogtreecommitdiff
path: root/tests/base32.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-09-14 18:07:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-09-14 21:40:15 +0200
commit7df42d3774778dfbb92e935df720f6eb52965e66 (patch)
treef52337308478c2be96071ea8148bda3104254662 /tests/base32.scm
parent63b75c01c2374edc38437215278f50b617a12c08 (diff)
downloadguix-7df42d3774778dfbb92e935df720f6eb52965e66.tar.gz
guix-7df42d3774778dfbb92e935df720f6eb52965e66.zip
gnu: r-hitc: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-hitc): Move from here... * gnu/packages/bioconductor.scm (r-hitc): ...to here. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'tests/base32.scm')
0 files changed, 0 insertions, 0 deletions