We want to allow builds in chroots that lack /bin/sh. Thus, system(3)
and popen(3) need to be tweaked to use the right shell. For the bootstrap
glibc, we just use whatever `sh' can be found in $PATH. The final glibc
instead uses the hard-coded absolute file name of `bash'.
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
@@ -106,8 +106,8 @@ do_system (const char *line)
(void) UNBLOCK;
/* Exec the shell. */
- (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ);
+ (void) execvp (SHELL_NAME, (char *const *) new_argv);
_exit (127);
}
else if (pid < (pid_t) 0)
/* The fork failed. */
--- a/libio/iopopen.c
+++ b/libio/iopopen.c
@@ -170,7 +170,7 @@ _IO_new_proc_open (fp, command, mode)
for (p = proc_file_chain; p; p = p->next)
_IO_close (_IO_fileno ((_IO_FILE *) p));
- _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0);
+ execlp ("sh", "sh", "-c", command, (char *) 0);
_IO__exit (127);
}
_IO_close (child_end);
'/guix/about/'>aboutsummaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2022-08-17 | time-travel-manifest: Use a separate cache per system....* etc/time-travel-manifest.scm (<guix-instance-compiler>): Use a separate
cache per system so that parallel system evaluations do no step on each
other's toes.
| Mathieu Othacehe |
2022-07-10 | time-travel-manifest: Use a separate Git checkout cache....* etc/time-travel-manifest.scm (guix-instance-compiler): Parameterize
%REPOSITORY-CACHE-DIRECTORY.
| Ludovic Courtès |
2022-07-08 | etc: Add 'time-travel-manifest.scm'....This manifest makes it easy to test travels from the current revision
back to the revision of a past Guix release.
Suggested by zimoun <zimon.toutoune@gmail.com>.
* etc/time-travel-manifest.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
| Ludovic Courtès |