We want to allow builds in chroots that lack /bin/sh. Thus, system(3) and popen(3) need to be tweaked to use the right shell. For the bootstrap glibc, we just use whatever `sh' can be found in $PATH. The final glibc instead uses the hard-coded absolute file name of `bash'. --- a/sysdeps/posix/system.c +++ b/sysdeps/posix/system.c @@ -106,8 +106,8 @@ do_system (const char *line) (void) UNBLOCK; /* Exec the shell. */ - (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ); + (void) execvp (SHELL_NAME, (char *const *) new_argv); _exit (127); } else if (pid < (pid_t) 0) /* The fork failed. */ --- a/libio/iopopen.c +++ b/libio/iopopen.c @@ -170,7 +170,7 @@ _IO_new_proc_open (fp, command, mode) for (p = proc_file_chain; p; p = p->next) _IO_close (_IO_fileno ((_IO_FILE *) p)); - _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0); + execlp ("sh", "sh", "-c", command, (char *) 0); _IO__exit (127); } _IO_close (child_end); ut/'>aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/docker.scm
AgeCommit message (Expand)Author
2020-10-17services: docker: Fix missing containerd-shim binary....Oleg Pykhalov
2020-09-23services: docker: Fix configuration....Oleg Pykhalov
2020-09-21services: Docker: Fix typo in configuration....Efraim Flashner
2020-09-21services: docker: Fix enable-proxy? option....Jesse Dowell
2020-09-15services: docker: Fix service definition....Oleg Pykhalov
2020-09-14services: docker: Fix service definition....Efraim Flashner
2020-09-14services: docker: Make docker command available....Efraim Flashner
2020-08-16services: docker: Add 'enable-iptables?' argument....Alexey Abramov
2020-06-03gnu: services: docker: Add a debug? parameter....Maxim Cournoyer