We want to allow builds in chroots that lack /bin/sh. Thus, system(3) and popen(3) need to be tweaked to use the right shell. For the bootstrap glibc, we just use whatever `sh' can be found in $PATH. The final glibc instead uses the hard-coded absolute file name of `bash'. --- a/sysdeps/posix/system.c +++ b/sysdeps/posix/system.c @@ -106,8 +106,8 @@ do_system (const char *line) (void) UNBLOCK; /* Exec the shell. */ - (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ); + (void) execvp (SHELL_NAME, (char *const *) new_argv); _exit (127); } else if (pid < (pid_t) 0) /* The fork failed. */ --- a/libio/iopopen.c +++ b/libio/iopopen.c @@ -170,7 +170,7 @@ _IO_new_proc_open (fp, command, mode) for (p = proc_file_chain; p; p = p->next) _IO_close (_IO_fileno ((_IO_FILE *) p)); - _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0); + execlp ("sh", "sh", "-c", command, (char *) 0); _IO__exit (127); } _IO_close (child_end); /'>aboutsummaryrefslogtreecommitdiff
path: root/tests/file-systems.scm
AgeCommit message (Expand)Author
2017-09-14uuid: Move tests to 'tests/uuid.scm'....Ludovic Courtès
2017-09-14uuid: Adjust tests....Ludovic Courtès
2017-03-21file-systems: Do not use (gnu packages …)....Ludovic Courtès
2017-02-04file-systems: Remove dependency on (guix store)....Ludovic Courtès
2017-01-16file-systems: 'file-system-needed-for-boot?' is #t for parents of the store....Ludovic Courtès
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin
2015-07-16file-systems: 'uuid' raises a syntax error for invalid UUIDs....Ludovic Courtès
2015-07-14file-systems: Allow users to specify file system UUIDs as strings....Ludovic Courtès