We want to allow builds in chroots that lack /bin/sh. Thus, system(3) and popen(3) need to be tweaked to use the right shell. For the bootstrap glibc, we just use whatever `sh' can be found in $PATH. The final glibc instead uses the hard-coded absolute file name of `bash'. --- a/sysdeps/posix/system.c +++ b/sysdeps/posix/system.c @@ -106,8 +106,8 @@ do_system (const char *line) (void) UNBLOCK; /* Exec the shell. */ - (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ); + (void) execvp (SHELL_NAME, (char *const *) new_argv); _exit (127); } else if (pid < (pid_t) 0) /* The fork failed. */ --- a/libio/iopopen.c +++ b/libio/iopopen.c @@ -170,7 +170,7 @@ _IO_new_proc_open (fp, command, mode) for (p = proc_file_chain; p; p = p->next) _IO_close (_IO_fileno ((_IO_FILE *) p)); - _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0); + execlp ("sh", "sh", "-c", command, (char *) 0); _IO__exit (127); } _IO_close (child_end); boutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
AgeCommit message (Expand)Author
2018-08-17gnu: ntp: Update to 4.2.8p12 [fix CVE-2018-12327]....* gnu/packages/ntp.scm (ntp): Update to 4.2.8p12. Tobias Geerinckx-Rice
2018-06-30gnu: tlsdate: Bump COMPILE_DATE....* gnu/packages/ntp.scm (tlsdate)[arguments]: Set COMPILE_DATE to 2018-06-28. Tobias Geerinckx-Rice
2018-06-29gnu: tlsdate: Return #t from phases....* gnu/packages/ntp.scm (tlsdate)[arguments]: Substitute INVOKE for SYSTEM*. Tobias Geerinckx-Rice
2018-04-11gnu: tlsdate: Fix compilation on aarch64-linux-gnu....* gnu/packages/ntp.scm (tlsdate)[arguments]: Add #:configure-flags. Ludovic Courtès
2018-03-28gnu: ntp: Update to 4.2.8p11 [security-fixes]....Fixes CVE-2016-1549 and CVE-2018-{7170,7182,7183,7184,7185}. * gnu/packages/ntp.scm (ntp): Update to 4.2.8p11. Leo Famulari
2018-03-05services: Add openntpd service....* gnu/packages/ntp.scm (openntpd)[arguments]: Add 'configure-flags to set openntpd daemon's user and localstatedir. Add a custom phase to not try to create said directory at install time. * gnu/services/networking.scm (<openntpd-configuration>): New record type. (openntpd-shepherd-service, openntpd-service-activation): New procedures. (openntpd-service-type): New variable. * doc/guix.texi (Networking Services): Add openntpd documentation. Efraim Flashner
2017-11-27gnu: openntpd: Enable use of TLS-based time constraints....* gnu/packages/ntp.scm (openntpd)[inputs]: Add libressl. Leo Famulari
2017-11-26gnu: openntpd: Update to 6.2p3....* gnu/packages/ntp.scm (openntpd): Update to 6.2p3. Efraim Flashner