This patch enables building glibc-2.2.5 using TCC and GNU Make 4.x and Mes C Library.
* Makefile: Do not assemble from stdin, use file indirection.
* Makefile: Add new target: install-lib-all.
* Makefile: Avoid building stub DOC.
* [_LIBC_REENTRANT]: Add missing guarding.
* [MES_BOOTSTRAP]: Disable some GCC extensions.
* [MES_BOOTSTRAP]: Add missing GCC div/mod defines.
Upstream status: Not presented upstream.
diff -purN -x .git -x fubar -x fubar.c -x Makefile -x config.status -x config.h -x BOOT -x BOOT-GCC -x texis -x '*.info*' ../glibc-2.2.5/config.h.in glibc-2.2.5/config.h.in
--- ../glibc-2.2.5/config.h.in 2001-11-16 02:02:56.000000000 +0100
+++ glibc-2.2.5/config.h.in 2018-06-17 21:30:02.313029074 +0200
@@ -1,3 +1,10 @@
+#if MES_BOOTSTRAP && BOOTSTRAP_GLIBC
+#undef __umoddi3
+#define __umoddi3(a,b) ((a)%(b))
+#undef __udivdi3
+#define __udivdi3(a,b) ((a)/(b))
+#endif
+
#if !defined ASSEMBLER && !defined _ISOMAC && !defined __OPTIMIZE__
# error "glibc cannot be compiled without optimization
gnu: kirigami-addons: Update to 0.8.0.
* gnu/packages/kde.scm (kirigami-addons): Update to 0.8.0.
[source]: Download using git-fetch.
0 files changed, 0 insertions, 0 deletions