Fix . Taken from this upstream commit, sans ChangeLog updates: https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=583dd860d5b833037175247230a328f0050dbfe9 diff --git a/posix/regexec.c b/posix/regexec.c index 91d5a797b8..084b1222d9 100644 --- a/posix/regexec.c +++ b/posix/regexec.c @@ -1293,8 +1293,10 @@ proceed_next_node (const re_match_context_t *mctx, Idx nregs, regmatch_t *regs, else if (naccepted) { char *buf = (char *) re_string_get_buffer (&mctx->input); - if (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx, - naccepted) != 0) + if (mctx->input.valid_len - *pidx < naccepted + || (memcmp (buf + regs[subexp_idx].rm_so, buf + *pidx, + naccepted) + != 0)) return -1; } } scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader.scm
AgeCommit message (Expand)Author
2019-01-16bootloader: Remove deprecated 'device' field....Ludovic Courtès
2018-04-08discovery: Remove dependency on (guix ui)....Ludovic Courtès
2017-08-28bootloader: Emit warnings with 'warning'....Ludovic Courtès
2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....Andy Wingo
2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic
2017-06-08bootloader: Use menu-entry to define custom bootloader entries....Mathieu Othacehe
2017-05-16bootloader: Add extlinux support....Mathieu Othacehe