From f6110a8fee2ca36f8e2d2abecf3cba9fa7b8ea7d Mon Sep 17 00:00:00 2001 From: Florian Weimer Date: Mon, 19 Jun 2017 17:09:55 +0200 Subject: [PATCH] CVE-2017-1000366: Ignore LD_LIBRARY_PATH for AT_SECURE=1 programs [BZ #21624] LD_LIBRARY_PATH can only be used to reorder system search paths, which is not useful functionality. This makes an exploitable unbounded alloca in _dl_init_paths unreachable for AT_SECURE=1 programs. patch from: https://sourceware.org/git/?p=glibc.git;a=commit;h=f6110a8fee2ca36f8e2d2abecf3cba9fa7b8ea7d --- ChangeLog | 7 +++++++ elf/rtld.c | 3 ++- 2 files changed, 9 insertions(+), 1 deletion(-) diff --git a/elf/rtld.c b/elf/rtld.c index 2446a87..2269dbe 100644 --- a/elf/rtld.c +++ b/elf/rtld.c @@ -2422,7 +2422,8 @@ process_envvars (enum mode *modep) case 12: /* The library search path. */ - if (memcmp (envline, "LIBRARY_PATH", 12) == 0) + if (!__libc_enable_secure + && memcmp (envline, "LIBRARY_PATH", 12) == 0) { library_path = &envline[13]; break; -- 2.9.3 '>summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
AgeCommit message (Expand)Author
2018-12-12gnu: CMake: Update to 3.13.1....Marius Bakke
2018-09-09gnu: cmake: Update to 3.12.2....Marius Bakke
2018-08-21gnu: cmake: Update to 3.12.1....Marius Bakke
2018-07-21gnu: cmake: Update to 3.12.0....Marius Bakke
2018-07-08gnu: cmake: Update to 3.11.4....Tobias Geerinckx-Rice
2018-06-12gnu: cmake: Update to 3.11.3....Tobias Geerinckx-Rice
2018-06-06Merge branch 'origin/core-updates-next' into core-updatesRicardo Wurmus
2018-05-25gnu: cmake: Delete Emacs library....Oleg Pykhalov
2018-05-24Merge branch 'master' into core-updatesMark H Weaver
2018-05-22Revert "gnu: cmake: Delete Emacs library."...Mark H Weaver
2018-05-22gnu: cmake.scm: Add missing module....Oleg Pykhalov
2018-05-22gnu: Add emacs-cmake-mode....Oleg Pykhalov
2018-05-22gnu: cmake: Delete Emacs library....Oleg Pykhalov
2018-04-30gnu: cmake: Update to 3.11.1....Marius Bakke
2018-03-29gnu: cmake: Update to 3.11.0....Marius Bakke
2018-03-23gnu: cmake: Re-indent....Arun Isaac
2018-03-23gnu: cmake: Update to 3.10.2....Arun Isaac
2018-03-04gnu: Add cmake@3.11....Marius Bakke