From f6110a8fee2ca36f8e2d2abecf3cba9fa7b8ea7d Mon Sep 17 00:00:00 2001 From: Florian Weimer Date: Mon, 19 Jun 2017 17:09:55 +0200 Subject: [PATCH] CVE-2017-1000366: Ignore LD_LIBRARY_PATH for AT_SECURE=1 programs [BZ #21624] LD_LIBRARY_PATH can only be used to reorder system search paths, which is not useful functionality. This makes an exploitable unbounded alloca in _dl_init_paths unreachable for AT_SECURE=1 programs. patch from: https://sourceware.org/git/?p=glibc.git;a=commit;h=f6110a8fee2ca36f8e2d2abecf3cba9fa7b8ea7d --- ChangeLog | 7 +++++++ elf/rtld.c | 3 ++- 2 files changed, 9 insertions(+), 1 deletion(-) diff --git a/elf/rtld.c b/elf/rtld.c index 2446a87..2269dbe 100644 --- a/elf/rtld.c +++ b/elf/rtld.c @@ -2422,7 +2422,8 @@ process_envvars (enum mode *modep) case 12: /* The library search path. */ - if (memcmp (envline, "LIBRARY_PATH", 12) == 0) + if (!__libc_enable_secure + && memcmp (envline, "LIBRARY_PATH", 12) == 0) { library_path = &envline[13]; break; -- 2.9.3 '>summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
AgeCommit message (Expand)Author
2024-07-19Revert "gnu: guile: Update to 3.0.10."...Ludovic Courtès
2024-07-19gnu: guile: Update to 3.0.10....David Thompson
2024-05-01gnu: guile-git: Update to 0.7.0....Ludovic Courtès
2024-04-30gnu: guile-next: Update to commit 3b76a30....David Thompson
2024-04-30gnu: guile-lzlib: Switch to ‘url-fetch’....Ludovic Courtès
2024-04-28gnu: guile-lzlib: Update to 0.3.0....Ludovic Courtès
2024-04-08gnu: guile-next: Update to commit db7efa5....David Thompson
2024-02-26gnu: guile-git: Depend on libgit2 1.7....Ludovic Courtès
2024-02-26gnu: guile-git: Update to 0.6.0....Ludovic Courtès
2024-02-12gnu: Add guile-bzip2....Timothy Sample
2024-02-02gnu: guile-next: Don't patch posix-spawn for the hurd....Christopher Baines
2024-01-29gnu: guile-next: Update to commit fb1f5e2....David Thompson
2023-11-28gnu: guile-next: Update to commit d8df317....David Thompson