From 146b58d11fddbef15b888906e3be4f33900c416f Mon Sep 17 00:00:00 2001 From: Florian Weimer Date: Tue, 29 Mar 2016 12:57:56 +0200 Subject: [PATCH] CVE-2016-3075: Stack overflow in _nss_dns_getnetbyname_r [BZ #19879] The defensive copy is not needed because the name may not alias the output buffer. (cherry picked from commit 317b199b4aff8cfa27f2302ab404d2bb5032b9a4) (cherry picked from commit 883dceebc8f11921a9890211a4e202e5be17562f) --- ChangeLog | 7 +++++++ NEWS | 10 ++++++++-- resolv/nss_dns/dns-network.c | 5 +---- 3 files changed, 16 insertions(+), 6 deletions(-) diff --git a/resolv/nss_dns/dns-network.c b/resolv/nss_dns/dns-network.c index 2eb2f67..8f301a7 100644 --- a/resolv/nss_dns/dns-network.c +++ b/resolv/nss_dns/dns-network.c @@ -118,17 +118,14 @@ _nss_dns_getnetbyname_r (const char *name, struct netent *result, } net_buffer; querybuf *orig_net_buffer; int anslen; - char *qbuf; enum nss_status status; if (__res_maybe_init (&_res, 0) == -1) return NSS_STATUS_UNAVAIL; - qbuf = strdupa (name); - net_buffer.buf = orig_net_buffer = (querybuf *) alloca (1024); - anslen = __libc_res_nsearch (&_res, qbuf, C_IN, T_PTR, net_buffer.buf->buf, + anslen = __libc_res_nsearch (&_res, name, C_IN, T_PTR, net_buffer.buf->buf, 1024, &net_buffer.ptr, NULL, NULL, NULL, NULL); if (anslen < 0) { -- 2.9.3 '>diff
path: root/.gitignore
AgeCommit message (Expand)Author
2018-11-20.gitignore: Re-add 'authenticate' script....Marius Bakke
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-12.gitignore: Add doc/stamp-[0-9].Ludovic Courtès
2018-04-19gnu: doc: Allow documentation to be translated....Julien Lepiller
2018-02-13.gitignore: Add guix-daemon SELinux policy....Efraim Flashner
2017-05-13.gitignore: Ignore Emacs auto-save files....ng0
2017-05-08build: Add doc/guix.html to .gitignore....Clément Lassieur
2017-05-04build: Use Gnulib's 'git-version-gen'....Ludovic Courtès
2017-02-27.gitignore: Remove stale entries....Alex Kost
2017-02-10build: Add build-aux/ar-lib to .gitignore....Clément Lassieur
2017-01-13etc: Support indentation of whole files....Ludovic Courtès
2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès