This patch is taken from debian's glibc package (generate-supported.mk). It install the localedata/SUPPORTED file of the glibc. This file lists all the supported locales of the glibc. diff --git a/localedata/Makefile b/localedata/Makefile index 65079f9eb8..14818f84e0 100644 --- a/localedata/Makefile +++ b/localedata/Makefile @@ -169,7 +169,8 @@ endif # Files to install. install-others := $(addprefix $(inst_i18ndir)/, \ $(addsuffix .gz, $(charmaps)) \ - $(locales)) + $(locales)) \ + $(inst_i18ndir)/SUPPORTED tests: $(objdir)/iconvdata/gconv-modules @@ -380,6 +381,14 @@ endif include SUPPORTED +$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force) + for locale in $(SUPPORTED-LOCALES); do \ + [ $$locale = true ] && continue; \ + echo $$locale | sed 's,/, ,' >> LOCALES; \ + done + $(make-target-directory) + $(INSTALL_DATA) LOCALES $@ + INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES)) INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES)) '/guix/'>summaryrefslogtreecommitdiff
path: root/gnu/packages/distributed.scm
AgeCommit message (Expand)Author
2020-03-26gnu: boinc-client: Update to 7.16.5....* gnu/packages/distributed.scm (boinc-client): Update to 7.16.5. Efraim Flashner
2020-03-26gnu: boinc-server: Fix build....* gnu/packages/distributed.scm (boinc-server)[inputs]: Replace openssl with openssl-1.0, mariadb with mariadb:dev. Efraim Flashner
2020-02-16gnu: boinc-client: Trim synopsis....* gnu/packages/distributed.scm (boinc-client)[synopsis]: Remove package name. Tobias Geerinckx-Rice
2020-02-16gnu: boinc-client: Update to 7.16.4....* gnu/packages/distributed.scm (boinc-client): Update to 7.16.4. Tobias Geerinckx-Rice
2019-12-23gnu: boinc-client: Update to 7.16.3....* gnu/packages/distributed.scm (boinc-client): Update to 7.16.3. Tobias Geerinckx-Rice
2019-10-12gnu: BOINC: Add a source file name....While at it, future-proof the URL as well. * gnu/packages/distributed.scm (boinc-client)[source](file-name): New field. Marius Bakke
2019-10-12gnu: BOINC: Update license....* gnu/packages/distributed.scm (boinc-client)[license]: Add LGPL3+. Marius Bakke
2019-10-12gnu: BOINC: Remove redundant comment....* gnu/packages/distributed.scm (boinc-client)[description]: Don't mention license terms. Marius Bakke
2019-09-24gnu: Add boinc-client and boinc-server....* gnu/packages/distributed.scm (boinc-client, boinc-server): New variable. Signed-off-by: Brian Leung <leungbk@mailfence.com> Brant Gardner