This patch is taken from debian's glibc package (generate-supported.mk). It install the localedata/SUPPORTED file of the glibc. This file lists all the supported locales of the glibc. diff --git a/localedata/Makefile b/localedata/Makefile index 65079f9eb8..14818f84e0 100644 --- a/localedata/Makefile +++ b/localedata/Makefile @@ -169,7 +169,8 @@ endif # Files to install. install-others := $(addprefix $(inst_i18ndir)/, \ $(addsuffix .gz, $(charmaps)) \ - $(locales)) + $(locales)) \ + $(inst_i18ndir)/SUPPORTED tests: $(objdir)/iconvdata/gconv-modules @@ -380,6 +381,14 @@ endif include SUPPORTED +$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force) + for locale in $(SUPPORTED-LOCALES); do \ + [ $$locale = true ] && continue; \ + echo $$locale | sed 's,/, ,' >> LOCALES; \ + done + $(make-target-directory) + $(INSTALL_DATA) LOCALES $@ + INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES)) INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES)) refslogtreecommitdiff
path: root/gnu/services/vpn.scm
AgeCommit message (Expand)Author
2020-02-19gnu: services: Add openvpn options....Julien Lepiller
2020-02-19gnu: services: Fix openvpn boolean fields....Julien Lepiller
2017-10-10services: vpn: Fix default tls-auth configuration....Julien Lepiller
2017-03-31doc: Fix typos....Eric Bavier
2017-03-24services: openvpn: Fix a typo which was corrected in generated doc....Mathieu Othacehe
2017-01-25services: Fix 'mkdir-p' in activation scripts....Clément Lassieur
2017-01-20services: Reindent vpn.scm....Ludovic Courtès
2017-01-15gnu: Add openvpn service....Julien Lepiller