This patch is taken from debian's glibc package (generate-supported.mk).
It install the localedata/SUPPORTED file of the glibc. This file lists
all the supported locales of the glibc.
diff --git a/localedata/Makefile b/localedata/Makefile
index 65079f9eb8..14818f84e0 100644
--- a/localedata/Makefile
+++ b/localedata/Makefile
@@ -169,7 +169,8 @@ endif
# Files to install.
install-others := $(addprefix $(inst_i18ndir)/, \
$(addsuffix .gz, $(charmaps)) \
- $(locales))
+ $(locales)) \
+ $(inst_i18ndir)/SUPPORTED
tests: $(objdir)/iconvdata/gconv-modules
@@ -380,6 +381,14 @@ endif
include SUPPORTED
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
+ for locale in $(SUPPORTED-LOCALES); do \
+ [ $$locale = true ] && continue; \
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
+ done
+ $(make-target-directory)
+ $(INSTALL_DATA) LOCALES $@
+
INSTALL-SUPPORTED-LOCALE-ARCHIVE=$(addprefix install-archive-, $(SUPPORTED-LOCALES))
INSTALL-SUPPORTED-LOCALE-FILES=$(addprefix install-files-, $(SUPPORTED-LOCALES))
ryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-02-09 | gnu: vorbis-tools: Update to 1.4.2....* gnu/packages/xiph.scm (vorbis-tools): Update to 1.4.2.
(source): Remove obsolete patches.
* gnu/packages/patches/vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch,
gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch,
gnu/packages/patches/vorbis-tools-CVE-2015-6749.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Signed-off-by: Leo Famulari <leo@famulari.name>
| Vincent Legoll |
2021-01-03 | gnu: libshout: Update to 2.4.5....* gnu/packages/xiph.scm (libshout): Update to 2.4.5.
| Tobias Geerinckx-Rice |
2020-10-13 | Merge branch 'master' into staging | Marius Bakke |
2020-10-06 | gnu: libshout: Update to 2.4.4....* gnu/packages/xiph.scm (libshout): Update to 2.4.4.
| Tobias Geerinckx-Rice |