This patch is taken from debian's glibc package (generate-supported.mk). It install the localedata/SUPPORTED file of the glibc. This file lists all the supported locales of the glibc. diff --git a/localedata/Makefile.old b/localedata/Makefile index 34877c0..a61d9b9 100644 --- a/localedata/Makefile.old +++ b/localedata/Makefile @@ -91,7 +91,8 @@ endif # Files to install. install-others := $(addprefix $(inst_i18ndir)/, \ $(addsuffix .gz, $(charmaps)) \ - $(locales)) + $(locales)) \ + $(inst_i18ndir)/SUPPORTED tests: $(objdir)/iconvdata/gconv-modules @@ -195,6 +196,14 @@ endif include SUPPORTED +$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force) + for locale in $(SUPPORTED-LOCALES); do \ + [ $$locale = true ] && continue; \ + echo $$locale | sed 's,/, ,' >> LOCALES; \ + done + $(make-target-directory) + $(INSTALL_DATA) LOCALES $@ + INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES)) # Sometimes the whole collection of locale files should be installed. summaryrefslogtreecommitdiff
path: root/gnu/machine
AgeCommit message (Expand)Author
2019-12-08machine: Remove unnecessary record self-referencing bindings....Ludovic Courtès
2019-12-07machine: ssh: Deprecate missing 'host-key' field....Ludovic Courtès
2019-12-04machine: ssh: <machine-ssh-configuration> can include the host key....Ludovic Courtès
2019-10-22machine: digital-ocean: Rename 'enable-ipv6' to 'enable-ipv6?'....Ludovic Courtès
2019-10-22machine: Implement 'digital-ocean-environment-type'....Jakob L. Kreuze
2019-08-17machine: ssh: Fix sanity checks....宋文武
2019-08-16machine: Use 'become-command'....Jakob L. Kreuze
2019-08-15machine: Automatically authorize the coordinator's signing key....Jakob L. Kreuze
2019-08-15machine: Implement 'roll-back-machine'....Jakob L. Kreuze
2019-08-15machine: Allow non-root users to deploy....Jakob L. Kreuze
2019-08-14remote: Build derivations appropriate for the remote's...Jakob L. Kreuze
2019-08-07machine: Add 'build-locally?' field for managed hosts....Jakob L. Kreuze
2019-08-06machine: Implement safety checks....Jakob L. Kreuze
2019-08-06machine: Rename 'system' field....Jakob L. Kreuze
2019-07-26guix system: Add 'reconfigure' module....Jakob L. Kreuze
2019-07-18machine: Fix typo....Tobias Geerinckx-Rice
2019-07-06gnu: Add machine type for deployment specifications....Jakob L. Kreuze