This patch is taken from debian's glibc package (generate-supported.mk).
It install the localedata/SUPPORTED file of the glibc. This file lists
all the supported locales of the glibc.
diff --git a/localedata/Makefile.old b/localedata/Makefile
index 34877c0..a61d9b9 100644
--- a/localedata/Makefile.old
+++ b/localedata/Makefile
@@ -91,7 +91,8 @@ endif
# Files to install.
install-others := $(addprefix $(inst_i18ndir)/, \
$(addsuffix .gz, $(charmaps)) \
- $(locales))
+ $(locales)) \
+ $(inst_i18ndir)/SUPPORTED
tests: $(objdir)/iconvdata/gconv-modules
@@ -195,6 +196,14 @@ endif
include SUPPORTED
+$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
+ for locale in $(SUPPORTED-LOCALES); do \
+ [ $$locale = true ] && continue; \
+ echo $$locale | sed 's,/, ,' >> LOCALES; \
+ done
+ $(make-target-directory)
+ $(INSTALL_DATA) LOCALES $@
+
INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
# Sometimes the whole collection of locale files should be installed.
/a>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2020-05-26 | gnu: pcre2: Update to 10.35....* gnu/packages/pcre.scm (pcre2): Update to 10.35.
| Marius Bakke |
2020-03-14 | gnu: pcre: Update to 8.44....* gnu/packages/pcre.scm (pcre): Update to 8.44.
| Marius Bakke |
2019-12-11 | gnu: pcre2: Do not build static libraries....* gnu/packages/pcre.scm (pcre2)[arguments]: Add "--disable-static" to
#:configure-flags.
| Marius Bakke |
2019-12-11 | gnu: pcre2: Update to 10.34....* gnu/packages/patches/pcre2-fix-jit_match-crash.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/pcre.scm (pcre2): Update to 10.34.
[source](patches): Remove.
| Marius Bakke |
2019-08-13 | Merge branch 'master' into core-updates | Marius Bakke |
2019-08-04 | gnu: Remove pcre2/fixed....* gnu/packages/pcre.scm (pcre2/fixed): Remove variable.
(pcre2)[replacement]: Remove.
[source](patches): New field.
* gnu/packages/php.scm (php)[inputs]: Change PCRE2/FIXED to PCRE2.
| Marius Bakke |
2019-08-02 | gnu: pcre@2: Fix run-time crash [security fix]....* gnu/packages/pcre.scm (pcre2)[replacement]: New field.
(pcre2/fixed): New public variable.
* packages/patches/pcre2-fix-jit_match-crash.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
| Tobias Geerinckx-Rice |