* On i686 floating-point roundoff errors could sometimes cause this check to fail depending on the elapsed microseconds. Improve rounding by adding a fractional bit. --- glib-2.40.0/glib/tests/timer.c 2014-03-05 08:05:42.000000000 -0600 +++ glib-2.40.0/glib/tests/timer.c 2014-07-10 16:33:12.746862822 -0500 @@ -35,7 +35,7 @@ elapsed = g_timer_elapsed (timer, µs); g_assert_cmpfloat (elapsed, <, 1.0); - g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6)) % 1000000); + g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6 + 0.5)) % 1000000); g_timer_destroy (timer); } 'hidden' name='id' value='b30b025c6f2d34ed32547a1f93cf36c2ed20af00'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/image.scm
AgeCommit message (Expand)Author
2021-02-17image: Export image? procedure....Mathieu Othacehe
2020-09-30image: Add image-type support....Mathieu Othacehe
2020-06-24image: Move hurd image definition to a dedicated file....Mathieu Othacehe
2020-06-13image: Add 'target' support....Mathieu Othacehe
2020-05-26image: Add partition file-system options support....Mathieu Othacehe
2020-05-26image: Set offset default to zero....Mathieu Othacehe
2020-05-26image: Add partition offset support....Mathieu Othacehe
2020-05-05image: Add a new API....Mathieu Othacehe