* On i686 floating-point roundoff errors could sometimes cause this check to fail depending on the elapsed microseconds. Improve rounding by adding a fractional bit. --- glib-2.40.0/glib/tests/timer.c 2014-03-05 08:05:42.000000000 -0600 +++ glib-2.40.0/glib/tests/timer.c 2014-07-10 16:33:12.746862822 -0500 @@ -35,7 +35,7 @@ elapsed = g_timer_elapsed (timer, µs); g_assert_cmpfloat (elapsed, <, 1.0); - g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6)) % 1000000); + g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6 + 0.5)) % 1000000); g_timer_destroy (timer); } nput type='hidden' name='id' value='bc6783d9c07be9003764fa345801d3fffe58c2ca'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/base.scm
AgeCommit message (Expand)Author
2024-01-22gnu: Remove linux-libre 4.14....Wilko Meyer
2023-04-21tests: Use the client 'start-service' procedure....Ludovic Courtès
2023-03-03services: dbus: Deprecate 'dbus-service' procedure....Bruno Victal
2023-01-08gnu: Remove linux-libre 4.9....Leo Famulari
2022-12-12tests: Add system tests for each supported kernel version....Marius Bakke
2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès
2022-11-17tests: root-unmount: Wait for the first QEMU process to finish....Ludovic Courtès
2022-10-07marionette: Make marionette-screen-text private....Maxim Cournoyer