* On i686 floating-point roundoff errors could sometimes cause this check to fail depending on the elapsed microseconds. Improve rounding by adding a fractional bit. * The /timer/stop test fails if compiler optimizations are enabled, which they are by default. Disable that test. --- glib-2.40.0/glib/tests/timer.c 2014-03-05 08:05:42.000000000 -0600 +++ glib-2.40.0/glib/tests/timer.c 2014-07-10 16:33:12.746862822 -0500 @@ -35,7 +35,7 @@ elapsed = g_timer_elapsed (timer, µs); g_assert_cmpfloat (elapsed, <, 1.0); - g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6)) % 1000000); + g_assert_cmpuint (micros, ==, ((guint64)(elapsed * 1e6 + 0.5)) % 1000000); g_timer_destroy (timer); } @@ -204,7 +204,6 @@ g_test_init (&argc, &argv, NULL); g_test_add_func ("/timer/basic", test_timer_basic); - g_test_add_func ("/timer/stop", test_timer_stop); g_test_add_func ("/timer/continue", test_timer_continue); g_test_add_func ("/timer/reset", test_timer_reset); g_test_add_func ("/timeval/add", test_timeval_add); uix/'>summaryrefslogtreecommitdiff
path: root/nix/libstore
AgeCommit message (Expand)Author
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2024-01-05daemon: Change default ‘timeout’ and ‘max-silent-time’ values....Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-11daemon: Implement ‘substitute-urls’ RPC....Ludovic Courtès
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2023-09-26daemon: Add “git-download” built-in builder....Ludovic Courtès
2023-09-09daemon: Fix build with GCC 13....Sören Tempel
2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2022-10-17Revert "nix: Guard against removing temporary roots of living processes."...Ludovic Courtès
2022-10-07nix: Guard against removing temporary roots of living processes....Ludovic Courtès
2022-09-11daemon: Remove unused function findOutput....Maxime Devos
2022-09-11daemon: Remove unused function exportPaths....Maxime Devos
2022-09-11daemon: Remove unused function openStore....Maxime Devos
2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice
2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org