Skip failing test in 'test_connection_binding_match_tls_unique'
in 'tls/tests/connection.c' when building glib-networking against
GnuTLS 3.7.2. The failure stems from the fact that
'gnutls_session_channel_binding' returns GNUTLS_E_INVALID_REQUEST
is known upstream:
https://gitlab.gnome.org/GNOME/glib-networking/-/issues/164
diff --git a/tls/tests/connection.c b/tls/tests/connection.c
index 036df04..347c7a4 100644
--- a/tls/tests/connection.c
+++ b/tls/tests/connection.c
@@ -3037,8 +3037,6 @@ main (int argc,
setup_connection, test_connection_missing_server_identity, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/peer-certificate-notify", TestConnection, NULL,
setup_connection, test_peer_certificate_notify, teardown_connection);
- g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-unique", TestConnection, NULL,
- setup_connection, test_connection_binding_match_tls_unique, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-server-end-point", TestConnection, NULL,
setup_connection, test_connection_binding_match_tls_server_end_point, teardown_connection);
g_test_add ("/tls/" BACKEND "/connection/binding/match-tls-exporter", TestConnection, NULL,
bility.scm?id=26709726a80de2d22ab129ff49b38dc1600bf8b2'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2023-09-04 | gnu: Add nsq....* gnu/packages/high-availability.scm (nsq): New variable.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Sharlatan Hellseher |
2023-07-16 | gnu: libqb: Tweak description....* gnu/packages/high-availability.scm (libqb)[synopsis]: Fix spelling.
[description]: Use @acronym{}.
| Tobias Geerinckx-Rice |
2023-07-16 | gnu: libqb: Update to 2.0.7....* gnu/packages/high-availability.scm (libqb): Update to 2.0.7.
| Tobias Geerinckx-Rice |
2023-07-16 | gnu: libqb: Fix cross-compilation....* gnu/packages/high-availability.scm (libqb)[native-inputs]:
Move libxml2 from here…
[inputs]: …to here.
| Tobias Geerinckx-Rice |
2023-07-16 | gnu: libqb: Remove obsolete bootstrapping inputs....* gnu/packages/high-availability.scm (libqb)[native-inputs]: Remove
autoconf, automake, and libtool.
| Tobias Geerinckx-Rice |
2023-04-09 | gnu: haproxy: Update to 2.7.6....* gnu/packages/high-availability.scm (haproxy): Update to 2.7.6.
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
| Yovan Naumovski |
2023-03-26 | gnu: haproxy: Move to (gnu packages high-availability)....Copyright records were synchronized based on commit history.
* gnu/packages/networking.scm (haproxy): Move this variable from here...
* gnu/packages/high-availability.scm (haproxy): ...to here.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Sharlatan Hellseher |