From 4506d1859a863087598c8d122740bae25b65b099 Mon Sep 17 00:00:00 2001 From: Simon McVittie Date: Mon, 8 Feb 2021 10:04:48 +0000 Subject: [PATCH 4/5] gtlspassword: Fix inverted assertion The intention here was to assert that the length of the password fits in a gssize. Passwords more than half the size of virtual memory are probably excessive. Fixes: a8b204ff "gtlspassword: Forbid very long TLS passwords" Signed-off-by: Simon McVittie (cherry picked from commit 61bb52ec42de1082bfb06ce1c737fc295bfe60b8) --- gio/gtlspassword.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/gio/gtlspassword.c b/gio/gtlspassword.c index dbcec41a8..bd86a6dfe 100644 --- a/gio/gtlspassword.c +++ b/gio/gtlspassword.c @@ -291,7 +291,7 @@ g_tls_password_set_value (GTlsPassword *password, { /* FIXME: g_tls_password_set_value_full() doesn’t support unsigned gsize */ gsize length_unsigned = strlen ((gchar *) value); - g_return_if_fail (length_unsigned > G_MAXSSIZE); + g_return_if_fail (length_unsigned <= G_MAXSSIZE); length = (gssize) length_unsigned; } -- 2.30.1 'active' href='/guix/log/gnu/packages/tbb.scm'>logtreecommitdiff
AgeCommit message (Expand)Author
2019-06-11gnu: tbb: Update to 2019_U8....Marius Bakke
2019-05-15gnu: tbb: Add a source file name....Marius Bakke
2019-05-15gnu: tbb: Update to 2019_U6....Marius Bakke
2019-03-21gnu: tbb: Update to 2019_U5....Marius Bakke
2019-03-18Correct name and email address for ng0....ng0
2018-03-20Merge branch 'master' into core-updatesMark H Weaver
2018-03-20Correct name and Email for ng0....ng0
2018-03-16gnu: All snippets report errors using exceptions, else return #t....Mark H Weaver
2016-10-08gnu: tbb: Update to 2017_20160916....Ricardo Wurmus
2016-09-26gnu: tbb: Fail on test errors....Ricardo Wurmus
2016-09-26gnu: tbb: Use modify-phases syntax....Ricardo Wurmus
2016-09-12gnu: tbb: Update to 2017....ng0