From e069c50467712e6d607822afd6b6c15c2c343dff Mon Sep 17 00:00:00 2001 From: Simon McVittie Date: Mon, 8 Feb 2021 10:34:50 +0000 Subject: [PATCH 2/5] giochannel: Don't store negative line_term_len in GIOChannel struct Adding test coverage indicated that this was another bug in 0cc11f74. Fixes: 0cc11f74 "giochannel: Forbid very long line terminator strings" Resolves: https://gitlab.gnome.org/GNOME/glib/-/issues/2323 Signed-off-by: Simon McVittie (cherry picked from commit 5dc8b0014c03e7491d93b90275ab442e888a9628) --- glib/giochannel.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/glib/giochannel.c b/glib/giochannel.c index 0d9d5f223..4c39b9dc0 100644 --- a/glib/giochannel.c +++ b/glib/giochannel.c @@ -903,7 +903,7 @@ g_io_channel_set_line_term (GIOChannel *channel, g_free (channel->line_term); channel->line_term = line_term ? g_memdup2 (line_term, length_unsigned) : NULL; - channel->line_term_len = length; + channel->line_term_len = length_unsigned; } /** -- 2.30.1 '/guix/'>summaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2019-08-31services: cups: Rename ‘retry-this-job’ to ‘retry-current-job’....Tobias Geerinckx-Rice
2019-08-30services: cups: Move SET-ENV to FILES-CONFIGURATION....Tobias Geerinckx-Rice
2019-08-30services: cups: Add BrowseDNSSDSubTypes directive....Tobias Geerinckx-Rice
2019-08-27services: cups: Update SSL-OPTIONS docstring....Tobias Geerinckx-Rice
2019-08-27services: cups: Complete SSL-OPTIONS....Tobias Geerinckx-Rice
2019-06-05services: cups: Create /var/cache on activation....Alex Griffin
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2018-06-22services: cups: Add description....Ricardo Wurmus
2017-04-16services: Add a default value to various service types....Ludovic Courtès
2017-03-12services: Move configuration functions that shouldn't be factorized....Clément Lassieur
2017-01-25services: Fix 'mkdir-p' in activation scripts....Clément Lassieur
2016-12-01services: cups: Follow symlinks when installing extensions....Andy Patterson
2016-11-26services: Factorize configuration abstraction....Julien Lepiller
2016-10-13gnu: Add CUPS service....Andy Wingo