This patch makes emission of /CreationDate and /ModDate headers optional.
If the environment variable GS_GENERATE_UUIDS is set to "0" or "no", it will
not write out the "/ID" field (if that's permissible).
Upstream does not want to do this.
See: https://bugs.ghostscript.com/show_bug.cgi?id=698208
diff --git a/orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c b/bb/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
index 0fb067e..b342e2c 100644
--- orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
+++ gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
@@ -305,6 +305,9 @@ pdf_initialize_ids(gx_device_pdf * pdev)
* date and time, rather than (for example) %%CreationDate from the
* PostScript file. We think this is wrong, but we do the same.
*/
+ if (!getenv("GS_GENERATE_UUIDS") ||
+ (strcasecmp(getenv("GS_GENERATE_UUIDS"), "0") != 0 &&
+ strcasecmp(getenv("GS_GENERATE_UUIDS"), "no") != 0))
{
struct tm tms;
time_t t;
tabs'>
aboutsummaryrefslogtreecommitdiff |
|
Age | Commit message (Expand) | Author |
2024-09-04 | gnu: screen: Update to 5.0.0...* gnu/packages/patches/screen-hurd-path-max.patch: Update for screen 5.0.0.
* gnu/packages/screen.scm (screen): Update to 5.0.0.
[arguments]<#:configure-flags: Add "-D_GNU_SOURCE=1" to CFLAGS.
[inputs]: Add linux-pam.
Change-Id: Iebc5eff0128ff7f4d27a22cca1bd4a025aca3244
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Andy Tai |
2024-08-31 | gnu: screen: Add libxcrypt dependency....* gnu/packages/screen.scm (screen)[inputs]: Add libxcrypt.
Change-Id: Ia8b7fce24603a038a52d57ef7177f588b66e006e
| Janneke Nieuwenhuizen |
2024-08-31 | gnu: byobu: Add 'bash' input for 'wrap-program'....It is required for cross-compilation.
* gnu/packages/screen.scm (byobu)[inputs]: Add 'bash-minimal'.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Maxime Devos |