The file names in the upstream patch below were modified to apply to GNU ghostscript. From 0c0b0859ae1aba64861599f0e7f74f143f305932 Mon Sep 17 00:00:00 2001 From: Chris Liddell Date: Tue, 7 Jul 2015 16:57:41 +0100 Subject: [PATCH] Bug 696041: sanity check for memory allocation. In gs_heap_alloc_bytes(), add a sanity check to ensure we don't overflow the variable holding the actual number of bytes we allocate. No cluster differences --- gs/base/gsmalloc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/base/gsmalloc.c b/base/gsmalloc.c index 624552d..cad79c2 100644 --- a/base/gsmalloc.c +++ b/base/gsmalloc.c @@ -178,7 +178,7 @@ gs_heap_alloc_bytes(gs_memory_t * mem, uint size, client_name_t cname) } else { uint added = size + sizeof(gs_malloc_block_t); - if (mmem->limit - added < mmem->used) + if (added <= size || mmem->limit - added < mmem->used) set_msg("exceeded limit"); else if ((ptr = (byte *) Memento_label(malloc(added), cname)) == 0) set_msg("failed"); -- 2.4.6 out/'>aboutsummaryrefslogtreecommitdiff
path: root/etc/guix-daemon.service.in
AgeCommit message (Collapse)Author
2022-10-23etc: systemd services shouldn't ‘RemainAfterExit’.Tobias Geerinckx-Rice
* etc/guix-daemon.service.in (RemainAfterExit): Don't. * etc/guix-publish.service.in (RemainAfterExit): Likewise don't.
2022-10-23etc: Add ‘Restart=always’ to both systemd services.Tobias Geerinckx-Rice
* etc/guix-daemon.service.in (Restart): ‘Always’ do. * etc/guix-publish.service.in (Restart): Likewise.
2022-10-23etc: Add ‘OOMPolicy=continue’ to guix-daemon.service.Tobias Geerinckx-Rice
* etc/guix-daemon.service.in (OOMPolicy): Continue.
2021-07-07guix-install.sh: Prompt for configuring substitutes discovery.Maxim Cournoyer
Also ensure prompt_yes_no always print the message with a trailing space, which is more pleasing to the eye. * etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option. * etc/guix-daemon.service.in: Likewise. * etc/init.d/guix-daemon.in: Likewise. * etc/openrc/guix-daemon.in: Likewise. * etc/guix-install.sh (configure_substitute_discovery): New procedure. (sys_enable_guix_daemon): Ask the user whether automatic substitute discovery should be enabled. Set the '--discover' argument accordingly. (prompt_yes_no): Add a trailing space to the message. (sys_authorize_build_farms): Remove trailing space from the message argument. * NEWS (Distribution): Add news.