Remove stray escapes to avoid warnings from grep 3.8 which breaks
expected test output.
diff --git a/testsuite/tests/hsc2hs/Makefile b/testsuite/tests/hsc2hs/Makefile
--- a/testsuite/tests/hsc2hs/Makefile
+++ b/testsuite/tests/hsc2hs/Makefile
@@ -47,5 +47,5 @@ T12504:
ifeq "$(WINDOWS)" "YES"
grep '{-# LINE 1 \"T12504\\\\path\\\\to\\\\$@\.hsc\" #-}' T12504/path/to/$@.hs
else
- grep '{-# LINE 1 \"T12504/path/to/$@\.hsc\" #-}' T12504/path/to/$@.hs
+ grep '{-# LINE 1 "T12504/path/to/$@\.hsc" #-}' T12504/path/to/$@.hs
endif
diff --git a/testsuite/tests/numeric/should_run/T7014.primops b/testsuite/tests/numeric/should_run/T7014.primops
--- a/testsuite/tests/numeric/should_run/T7014.primops
+++ b/testsuite/tests/numeric/should_run/T7014.primops
@@ -1,8 +1,8 @@
and#
or#
uncheckedShift.*#
-\+#
-\-#
++#
+-#
\*#
quotInt#
remInt#
diff --git a/testsuite/tests/simplCore/should_compile/Makefile b/testsuite/tests/simplCore/should_compile/Makefile
--- a/testsuite/tests/simplCore/should_compile/Makefile
+++ b/testsuite/tests/simplCore/should_compile/Makefile
@@ -226,7 +226,7 @@ str-rules:
# g should have been collapsed into one defininition by CSE.
.PHONY: T13340
T13340:
- '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '\+#'
+ '$(TEST_HC)' $(TEST_HC_OPTS) -c -O T13340.hs -ddump-simpl -dsuppress-all | grep -c '+#'
# We expect to see all dictionaries specialized away.
f/gnu/packages/ipfs.scm?id=0be51fe03bf2b8f3ef009929fa0860e17aa15de4'>diff
|
Age | Commit message (Expand) | Author |
2023-10-05 | gnu: go-ipfs: Update to 0.14.0....* gnu/packages/ipfs.scm (go-ipfs): Update to 0.14.0.
[source]: Change "go-ipfs" to "kubo" in the source link.
[arguments]: Rename "go-ipfs" to "kubo".
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Artyom V. Poptsov |
2023-09-14 | gnu: go-ipfs: Update to 0.13.0....* gnu/packages/ipfs.scm (go-ipfs): Update to 0.13.0.
[inputs]: Add GO-GOLANG-ORG-X-{EXP,TEXT}.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Artyom V. Poptsov |