https://github.com/vincenthz/hs-memory/commit/2738929ce15b4c8704bbbac24a08539b5d4bf30e.patch https://github.com/vincenthz/hs-memory/pull/99 Adjusted so the '904' becomes '902' From 2738929ce15b4c8704bbbac24a08539b5d4bf30e Mon Sep 17 00:00:00 2001 From: sternenseemann Date: Mon, 14 Aug 2023 10:51:30 +0200 Subject: [PATCH] Data.Memory.Internal.CompatPrim64: fix 32 bit with GHC >= 9.4 Since 9.4, GHC.Prim exports Word64# operations like timesWord64# even on i686 whereas GHC.IntWord64 no longer exists. Therefore, we can just use the ready made solution. Closes #98, as it should be the better solution. --- Data/Memory/Internal/CompatPrim64.hs | 4 ++++ 1 file changed, 4 insertions(+) diff --git a/Data/Memory/Internal/CompatPrim64.hs b/Data/Memory/Internal/CompatPrim64.hs index b9eef8a..a134c88 100644 --- a/Data/Memory/Internal/CompatPrim64.hs +++ b/Data/Memory/Internal/CompatPrim64.hs @@ -150,6 +150,7 @@ w64# :: Word# -> Word# -> Word# -> Word64# w64# w _ _ = w #elif WORD_SIZE_IN_BITS == 32 +#if __GLASGOW_HASKELL__ < 902 import GHC.IntWord64 import GHC.Prim (Word#) @@ -158,6 +159,9 @@ timesWord64# a b = let !ai = word64ToInt64# a !bi = word64ToInt64# b in int64ToWord64# (timesInt64# ai bi) +#else +import GHC.Prim +#endif w64# :: Word# -> Word# -> Word# -> Word64# w64# _ hw lw = 553a478'>commitdiff
path: root/tests/gem.scm
AgeCommit message (Expand)Author
2020-04-27tests: Remove trailing commas in JSON tests....Ludovic Courtès
2020-02-05import: gem: Deal with unavailable licensing info....Ludovic Courtès
2019-12-11import: utils: 'recursive-import' returns a list rather than a stream....Ludovic Courtès
2019-12-11import: utils: 'recursive-import' returns packages in topological order....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-07-11import: gem: Add recursive import....Oleg Pykhalov
2017-02-13tests: Adjust for 'http-fetch' change in (guix import json)....Ludovic Courtès
2016-12-18tests: Mock up http-fetch in import tests....Ricardo Wurmus
2016-08-28import: Importers return prefixed licenses....David Craven
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin
2016-01-20import: gem: Beautify only the description, not the synopsis....Ben Woodcroft
2015-09-01import: gem: Fix minor bug and add unit test....David Thompson