Compatibility with GHC 8.10 and template-haskell 2.16.
Taken from
https://raw.githubusercontent.com/archlinux/svntogit-community/packages/haskell-language-haskell-extract/trunk/ghc-8.10.patch
diff --git a/src/Language/Haskell/Extract.hs b/src/Language/Haskell/Extract.hs
index 3e8958b..43dfe04 100644
--- a/src/Language/Haskell/Extract.hs
+++ b/src/Language/Haskell/Extract.hs
@@ -1,3 +1,4 @@
+{-# LANGUAGE CPP #-}
module Language.Haskell.Extract (
functionExtractor,
functionExtractorMap,
@@ -25,7 +26,11 @@ extractAllFunctions pattern =
functionExtractor :: String -> ExpQ
functionExtractor pattern =
do functions <- extractAllFunctions pattern
- let makePair n = TupE [ LitE $ StringL n , VarE $ mkName n]
+ let makePair n = TupE
+#if MIN_VERSION_template_haskell(2,16,0)
+ $ map Just
+#endif
+ [ LitE $ StringL n , VarE $ mkName n]
return $ ListE $ map makePair functions
='tabs'>
aboutsummaryrefslogtreecommitdiff |
|
Age | Commit message (Expand) | Author |
2023-11-05 | tests: Honor system and target when lowering <system-test>....* gnu/tests.scm (compile-system-test): Wrap ‘system-test-value’ call in
‘mparameterize’.
Change-Id: I4be28913a86f43059b0886ad2fcf81a9c699b730
| Ludovic Courtès |
2023-04-21 | tests: Fork and exec a new Guile for the marionette REPL....By merely forking PID 1, details from PID 1 (shepherd) would leak into
the marionette process, such as the set of modules in scope and state
inherited from the shepherd process (<service> instances, fibers,
etc.). Running a fresh Guile instance avoids that.
* gnu/tests.scm (marionette-program): New procedure.
(marionette-shepherd-service): Change 'start' to use
'make-forkexec-constructor', and run the result of 'marionette-program'.
| Ludovic Courtès |