This patch is taken and adapted from upstream. It landed shortly after the release of 0.31.2, and fixes eleven tests. The patch has been lightly adapted to apply to the release tarball, but the commit message was left untouched, so it refers to some changes not included in the patch. From a8d9362d4b686074f698c04c20beea88587511a1 Mon Sep 17 00:00:00 2001 From: quasicomputational Date: Sat, 1 Jun 2019 15:11:31 +0100 Subject: [PATCH] Make CI green (#345) * AppVeyor workaround for TMP issue https://github.com/commercialhaskell/stack/issues/3944 * Bump resolver to nightly-2018-12-12. This has the primary benefit of moving to GHC 8.6.3 and should fix AppVeyor. * Add clock 0.8 as an extra-dep. * Adapt expected output to aeson 1.4.3.0. --- appveyor.yml | 3 +++ hpack.cabal | 10 +++++----- package.yaml | 2 +- stack.yaml | 5 +++-- test/Data/Aeson/Config/FromV
aboutsummaryrefslogtreecommitdiff
path: root/etc/gnu-store.mount.in
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-04 08:23:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-04 10:01:08 +0100
commit669d3a757076d3efbc914ec6294ebcf8bc358617 (patch)
tree5d3385d0f694a38387f276071d474938d73e2206 /etc/gnu-store.mount.in
parentf593b5e92b8eecb3e69820417d754c03cd66cde3 (diff)
downloadguix-669d3a757076d3efbc914ec6294ebcf8bc358617.tar.gz
guix-669d3a757076d3efbc914ec6294ebcf8bc358617.zip
gnu: r-vctrs: Update to 0.5.0.
* gnu/packages/cran.scm (r-vctrs): Update to 0.5.0. [propagated-inputs]: Add r-lifecycle.
Diffstat (limited to 'etc/gnu-store.mount.in')
0 files changed, 0 insertions, 0 deletions
r" :: Result Cond) describe "formatOrList" $ do it "formats a singleton list" $ do diff --git a/test/Hpack/Syntax/DefaultsSpec.hs b/test/Hpack/Syntax/DefaultsSpec.hs index 5875413..5438b7a 100644 --- a/test/Hpack/Syntax/DefaultsSpec.hs +++ b/test/Hpack/Syntax/DefaultsSpec.hs @@ -151,4 +151,4 @@ spec = do it "fails" $ do [yaml| 10 - |] `shouldDecodeTo` left "Error while parsing $ - expected Object or String, encountered Number" + |] `shouldDecodeTo` left "Error while parsing $ - expected Object or String, but encountered Number" diff --git a/test/Hpack/Syntax/DependenciesSpec.hs b/test/Hpack/Syntax/DependenciesSpec.hs index 1a83732..d95044f 100644 --- a/test/Hpack/Syntax/DependenciesSpec.hs +++ b/test/Hpack/Syntax/DependenciesSpec.hs @@ -125,7 +125,7 @@ spec = do it "rejects invalid values" $ do [yaml| hpack: [] - |] `shouldDecodeTo` left "Error while parsing $.hpack - expected Null, Object, Number, or String, encountered Array" + |] `shouldDecodeTo` left "Error while parsing $.hpack - expected Null, Object, Number, or String, but encountered Array" context "when the constraint is a Number" $ do it "accepts 1" $ do @@ -213,7 +213,7 @@ spec = do [yaml| foo: version: {} - |] `shouldDecodeTo` left "Error while parsing $.foo.version - expected Null, Number, or String, encountered Object" + |] `shouldDecodeTo` left "Error while parsing $.foo.version - expected Null, Number, or String, but encountered Object" it "accepts a string" $ do [yaml| -- 2.23.0