Don’t add linker flags via ‘response files’ since ld-wrapper doesn’t handle them. See https://github.com/NixOS/nixpkgs/commit/a421e7bd4a28c69bded8b17888325e31554f61a1 https://gcc.gnu.org/ml/gcc/2016-10/msg00151.html diff --git a/compiler/main/SysTools.hs.orig b/compiler/main/SysTools.hs index 1ab5b13..99270fc 100644 --- a/compiler/main/SysTools.hs.orig +++ b/compiler/main/SysTools.hs @@ -424,7 +424,7 @@ runCc dflags args = do args1 = map Option (getOpts dflags opt_c) args2 = args0 ++ args1 ++ args mb_env <- getGccEnv args2 - runSomethingResponseFile dflags cc_filter "C Compiler" p args2 mb_env + runSomethingFiltered dflags cc_filter "C Compiler" p args2 mb_env where -- discard some harmless warnings from gcc that we can't turn off cc_filter = unlines . doFilter . lines @@ -945,7 +945,7 @@ runLink dflags args = do args1 = map Option (getOpts dflags opt_l) args2 = args0 ++ linkargs ++ args1 ++ args mb_env <- getGccEnv args2 - runSomethingResponseFile dflags ld_filter "Linker" p args2 mb_env + runSomethingFiltered dflags ld_filter "Linker" p args2 mb_env where ld_filter = case (platformOS (targetPlatform dflags)) of OSSolaris2 -> sunos_ld_filter 4d4cda9fe83d5ae900214b4b844'>treecommitdiff
path: root/gnu/build/file-systems.scm
AgeCommit message (Expand)Author
2021-11-23system: Add swap flags....Josselin Poiret
2021-09-28file-systems: Prefer low-memory mode of ‘btrfs check’....Tobias Geerinckx-Rice
2021-09-23file-systems: Add support for XFS....Tobias Geerinckx-Rice
2021-09-23file-systems: Add file system to *-SUPERBLOCK-VOLUME-NAME docstrings....Tobias Geerinckx-Rice
2021-09-23gnu: Don't abuse check-btrfs-file-system to scan....Tobias Geerinckx-Rice
2021-09-23file-systems: Support forced checks & repairs....Tobias Geerinckx-Rice
2021-05-04file-systems: Rewrite comment....Tobias Geerinckx-Rice
2021-05-04file-systems: Handle abnormal ‘bcachefs fsck’ exits....Tobias Geerinckx-Rice
2021-04-23file-systems: read-partition-{uuid,label} don't swallow ENOENT & co....Ludovic Courtès
2021-03-10file-systems: 'mount-file-system' preserves the right mount flags....Ludovic Courtès
2021-02-25file-systems: 'mount-file-system' preserves source flags for bind mounts....Ludovic Courtès
2020-12-06file-systems: Fix ‘bcachefs fsck’ exit value logic....Tobias Geerinckx-Rice
2020-11-07file-systems: Add support for bcachefs....Tobias Geerinckx-Rice
2020-10-30file-systems: Allow swap space lookup by UUID/label....Ludovic Courtès
2020-09-07linux-boot: Handle nfs-root device strings....Stefan