Don’t add linker flags via ‘response files’ since ld-wrapper doesn’t handle them. See https://github.com/NixOS/nixpkgs/commit/a421e7bd4a28c69bded8b17888325e31554f61a1 https://gcc.gnu.org/ml/gcc/2016-10/msg00151.html diff --git a/compiler/main/SysTools.hs.orig b/compiler/main/SysTools.hs index 1ab5b13..99270fc 100644 --- a/compiler/main/SysTools.hs.orig +++ b/compiler/main/SysTools.hs @@ -424,7 +424,7 @@ runCc dflags args = do args1 = map Option (getOpts dflags opt_c) args2 = args0 ++ args1 ++ args mb_env <- getGccEnv args2 - runSomethingResponseFile dflags cc_filter "C Compiler" p args2 mb_env + runSomethingFiltered dflags cc_filter "C Compiler" p args2 mb_env where -- discard some harmless warnings from gcc that we can't turn off cc_filter = unlines . doFilter . lines @@ -945,7 +945,7 @@ runLink dflags args = do args1 = map Option (getOpts dflags opt_l) args2 = args0 ++ linkargs ++ args1 ++ args mb_env <- getGccEnv args2 - runSomethingResponseFile dflags ld_filter "Linker" p args2 mb_env + runSomethingFiltered dflags ld_filter "Linker" p args2 mb_env where ld_filter = case (platformOS (targetPlatform dflags)) of OSSolaris2 -> sunos_ld_filter ea5fb856e406a5a'>treecommitdiff
path: root/gnu/packages/golang.scm
AgeCommit message (Expand)Author
2017-02-16gnu: go: Update to 1.7.5....* gnu/packages/golang.scm (go-1.7): Update to 1.7.5. [arguments]: Re-enable test 'TestLoadFixed'. Leo Famulari
2016-12-04gnu: Fix header in (gnu packages golang)....* gnu/packages/golang.scm: Replace header line declaring this file as part of GNU Guix. Efraim Flashner
2016-12-02gnu: go-1.7: Update to 1.7.4 [security fixes]....* gnu/packages/golang.scm (go-1.7): Update to 1.7.4. Leo Famulari
2016-10-23Merge branch 'master' into core-updatesMark H Weaver
2016-10-21gnu: go-1.7: Skip test that fails due to time zone name change....* gnu/packages/golang.scm (go-1.7)[arguments]: Skip test "TestLoadFixed" in 'prebuild' phase. Leo Famulari
2016-10-21gnu: go-1.4: Skip test that fails due to time zone name change....* gnu/packages/golang.scm (go-1.4)[arguments]: Skip test "TestLoadFixed" in 'prebuild' phase. Leo Famulari
2016-10-21gnu: go-1.4: Disable cgo....* gnu/packages/golang.scm (go-1.4)[arguments]: Set "CGO_ENABLED=0" while building. (go-1.7)[arguments]: Keep "CGO_ENABLED=1". Leo Famulari
2016-10-21gnu: go-1.7: Update to 1.7.3....* gnu/packages/golang.scm (go-1.7): Update to 1.7.3. Leo Famulari
2016-09-11gnu: go-1.7: Update to 1.7.1....* gnu/packages/golang.scm (go-1.7): Update to 1.7.1. Leo Famulari
2016-09-06gnu: go: Update to 1.7....* gnu/packages/golang.scm (go-1.6): Update to 1.7, with corresponding minor changes to prebuild phase, and rename variable to... (go-1.7): ...this new variable. (go): Inherit from new "go-1.7". Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Petter
2016-08-01gnu: Add Go 1.6....* gnu/packages/golang.scm (go-1.6): New variable. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> Co-authored-by: Andy Wingo <wingo@igalia.com> Co-authored-by: Ludovic Courtès <ludo@gnu.org> Matthew Jordan
2016-06-27gnu: Add Go 1.4....* gnu/local.mk: Modified file. * gnu/packages/golang.scm: New file. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> Co-authored-by: Andy Wingo <wingo@igalia.com> Co-authored-by: Ludovic Courtès <ludo@gnu.org> Matthew Jordan