Allow the configuration file to be specified via an environment variable.
--- geoclue-2.1.10/src/gclue-config.c 2015-04-07 09:50:07.721074380 +0200
+++ geoclue-2.1.10/src/gclue-config.c 2015-04-07 10:27:26.613171960 +0200
@@ -235,6 +235,11 @@
gclue_config_init (GClueConfig *config)
{
GError *error = NULL;
+ const char *config_file_path;
+
+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
+ if (config_file_path == NULL)
+ config_file_path = CONFIG_FILE_PATH;
config->priv =
G_TYPE_INSTANCE_GET_PRIVATE (config,
@@ -242,7 +247,7 @@
GClueConfigPrivate);
config->priv->key_file = g_key_file_new ();
g_key_file_load_from_file (config->priv->key_file,
- CONFIG_FILE_PATH,
+ config_file_path,
0,
&error);
if (error != NULL) {
d class='sub right'>
Age | Commit message (Expand) | Author |
2021-06-04 | gnu: smalltalk: Find glibc even when cross-compiling....glibc is named "cross-libc" instead of "libc" when cross-compiling. Smalltalk
still fails to cross-compile though.
* gnu/packages/smalltalk.scm
(smalltalk)[arguments]{phases}<#:fix-libc>: Also search for
"cross-libc" instead of only "libc" in 'inputs'.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Maxime Devos |
2021-06-04 | gnu: smalltalk: Move 'zip' from 'inputs' to 'native-inputs'....The 'zip' package is not in the references of 'smalltalk'.
As such, it probably should be a native input, not a regular
input. This can be confirmed by trying to cross-compile
the 'smalltalk' package, without this commit. The configure
script will ask to install InfoZIP.
* gnu/packages/smalltalk.scm
(smalltalk)[inputs]{zip}: Move to ...
(smalltalk)[native-inputs]{zip} ... here.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Maxime Devos |
2021-06-04 | gnu: smalltalk: Use 'inputs' in phases instead of '%build-inputs'....In build phases, the former is preferred.
* gnu/packages/smalltalk.scm
(smalltalk)[arguments]<#:phases>{fix-libc}: Use 'inputs'
argument instead of '%build-inputs'.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Maxime Devos |