Get wayland-session wrapper from environment.
diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
index 3b83fcd3..e60e6a57 100644
--- a/daemon/gdm-session.c
+++ b/daemon/gdm-session.c
@@ -2933,8 +2933,9 @@ gdm_session_start_session (GdmSession *self,
allow_remote_connections? "--allow-remote-connections " : "",
command);
} else {
- program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s\"",
+ program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s %s\"",
register_session ? "--register-session " : "",
+ g_getenv ("GDM_WAYLAND_SESSION"),
command);
}
} else if (run_xsession_script) {
@@ -2965,8 +2966,9 @@ gdm_session_start_session (GdmSession *self,
register_session ? "--register-session " : "",
self->selected_program);
} else {
- program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"dbus-run-session -- %s\"",
+ program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"dbus-run-session -- %s %s\"",
register_session ? "--register-session " : "",
+ g_getenv ("GDM_WAYLAND_SESSION"),
self->selected_program);
}
} else {
m>
Age | Commit message (Expand) | Author |
2022-04-02 | nls: Update translations....* po/packages/fi.po: New file.
* po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-03-01 | nls: Update translations....* po/doc/guix-cookbook.uk.po: New file.
* po/doc/local.mk: Add uk cookbook.
* doc/local.mk: Add uk cookbook.
* po/guix/fa.po: New file.
* po/guix/uk.po: New file.
* po/guix/LINGUAS: Add fa and uk.
| Julien Lepiller |
2022-02-04 | nls: Update translations....* po/doc/guix-cookbook.pt_BR.po: New file.
* po/doc/local.mk: Add it.
* doc/local.mk: Add pt_BR cookbook.
| Julien Lepiller |
2022-01-09 | nls: Update translations....* po/doc/guix-cookbook.fi.po: New file.
* po/doc/guix-manual.fi.po: New file.
* po/doc/local.mk: Add them.
* doc/local.mk: Add them.
* po/guix/fi.po: New file.
* po/guix/LINGUAS: Add it.
| Julien Lepiller |
2021-12-04 | nls: Update translations. | Julien Lepiller |
2021-11-06 | nls: Update translations....* po/doc/guix-cookbook.es.po: New file.
* po/doc/local.mk: Add 'es' cookbook.
* doc/local.mk: Add 'es' cookbook.
| Julien Lepiller |
2021-10-17 | nls: Update translations. | Julien Lepiller |
2021-09-02 | nls: Update translations....* po/packages/it.po: New file.
* po/packages/LINGUAS: Add `it'.
* po/*/*.po: Update translations.
| Julien Lepiller |
2021-08-04 | nls: Update translations....* po/doc/guix-cookbook.ru.po: New file.
* po/doc/guix-cookbook.sk.po: New file.
* po/*/*.po: Update translations.
* doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk.
(info_TEXINFOS): Add Russian and Slovak cookbooks.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po
files.
| Julien Lepiller |
2021-05-10 | nls: Update translations. | Maxim Cournoyer |
2021-04-18 | nls: Update 'pl' translations. | Julien Lepiller |