Get wayland-session wrapper from environment.
diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
index 3b83fcd3..e60e6a57 100644
--- a/daemon/gdm-session.c
+++ b/daemon/gdm-session.c
@@ -2933,8 +2933,9 @@ gdm_session_start_session (GdmSession *self,
allow_remote_connections? "--allow-remote-connections " : "",
command);
} else {
- program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s\"",
+ program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"%s %s\"",
register_session ? "--register-session " : "",
+ g_getenv ("GDM_WAYLAND_SESSION"),
command);
}
} else if (run_xsession_script) {
@@ -2965,8 +2966,9 @@ gdm_session_start_session (GdmSession *self,
register_session ? "--register-session " : "",
self->selected_program);
} else {
- program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"dbus-run-session -- %s\"",
+ program = g_strdup_printf (LIBEXECDIR "/gdm-wayland-session %s\"dbus-run-session -- %s %s\"",
register_session ? "--register-session " : "",
+ g_getenv ("GDM_WAYLAND_SESSION"),
self->selected_program);
}
} else {
guix/log/?id=211ea54122f3f72220dbe39dfbb86e506be925b9'>root/bootstrap
Age | Commit message (Expand) | Author |
2021-06-13 | bootstrap: Simplify search for translation languages....Extend the sed script to also behave like "basename",
saving the addtional call of "xargs basename".
* bootstrap (langs): Extend sed scripts, remove running xargs.
| Hartmut Goebel |
2020-02-17 | bootstrap: Fix typo....* bootstrap: Substitute ‘guix-cookbook’ for copy/pasted ‘guix-manual’.
Reported-by: jetomit on #guix
| Tobias Geerinckx-Rice |
2019-09-18 | doc: Add Guix Cookbook....* .gitignore: Update ignore list.
* Makefile.am (assert-no-store-file-names): Exclude the cookbook.
* bootstrap: Generate po files for cookbook translations.
* doc/guix-cookbook.texi: New file.
* doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook
translations.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable.
(EXTRA_DIST): Add cookbook pot file and po files.
(doc-po-update-cookbook-%): New target.
(doc-pot-update): Also update cookbook pot file.
(doc-po-update): Also update cookbook po files.
| Ricardo Wurmus |
2019-04-26 | bootstrap: Break automake dependency on generated files....* bootstrap: Generate stub files for the manual translations whose
generated files are not included in the VCS.
* doc/contributing.de.texi: Remove file.
* doc/contributing.es.texi: Remove file.
* doc/contributing.fr.texi: Remove file.
* doc/contributing.zh_CN.texi: Remove file.
* doc/guix.de.texi: Remove file.
* doc/guix.es.texi: Remove file.
* doc/guix.fr.texi: Remove file.
* doc/guix.zh_CN.texi: Remove file.
* .gitignore: Add them.
Signed-off-by: Julien Lepiller <julien@lepiller.eu>
| Miguel Ángel Arruga Vivas |