This patch comes from Debian. https://bugzilla.gnome.org/show_bug.cgi?id=771052 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835737 --- gcr-3.20.0.old/gcr/test-gnupg-collection.c 2017-06-29 14:26:33.810838197 -0400 +++ gcr-3.20.0/gcr/test-gnupg-collection.c 2017-06-30 17:25:09.149383067 -0400 @@ -115,6 +115,14 @@ g_object_unref (test->collection); + /* remove potential gpg 2.1 extras, ignore any errors. */ + cmd = g_strdup_printf ("rm -rf %s/*.d", test->directory); + system(cmd); + g_free(cmd); + cmd = g_strdup_printf ("rm -f %s/.gpg-v21-migrated", test->directory); + system(cmd); + g_free(cmd); + cmd = g_strdup_printf ("rm -f %s/*", test->directory); g_spawn_check_exit_status (system (cmd), &error); g_assert_no_error (error); @@ -202,7 +210,7 @@ GcrGnupgKey *key; _gcr_gnupg_collection_load_async (test->collection, NULL, on_async_ready, test); - egg_test_wait_until (500); + egg_test_wait_until (2500); g_assert (test->result); _gcr_gnupg_collection_load_finish (test->collection, test->result, &error); g_assert_no_error (error); e536b4ba22fae'>refslogtreecommitdiff
path: root/HACKING
AgeCommit message (Expand)Author
2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual....Ludovic Courtès
2020-01-09doc: Add "Tracking Bugs and Patches" section....Ludovic Courtès
2019-07-13doc: Update keyserver URL....Leo Famulari
2019-02-11HACKING: Update key server....Ludovic Courtès
2018-07-22doc: Fix typo (missing period)...Pierre Neidhardt
2017-08-19doc: Mention how to use emacs-debbugs....Arun Isaac
2017-03-27maint: Give command to install the pre-push hook....Ludovic Courtès
2017-03-24maint: Mention the Signed-off-by line in 'HACKING'....Clément Lassieur
2017-03-15maint: Mention guix-patches@gnu.org in 'HACKING'....Ludovic Courtès
2017-01-30maint: Fix invalid calls to 'info'....Mathieu Lirzin
2017-01-04doc: Add a Git hook that verifies signatures before pushing....Leo Famulari
2016-07-24doc: Explain how to set up Git for signing....Ludovic Courtès
2016-07-14doc: Mention commit signatures in HACKING....Leo Famulari
2015-06-14doc: Move most 'HACKING' informations into the manual....Mathieu Lirzin
2015-06-10doc: Add 'help2man' to HACKING....Alex Kost
2015-05-23doc: Add "Running Guix Before It Is Installed"....Ludovic Courtès
2015-02-26doc: Remove reference to git submodules in HACKING....Mark H Weaver
2014-09-03doc: Mention 'guix lint' and '--list-dependent' in 'HACKING'....Ludovic Courtès