This patch comes from Debian.
https://bugzilla.gnome.org/show_bug.cgi?id=771052
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=835737
--- gcr-3.20.0.old/gcr/test-gnupg-collection.c 2017-06-29 14:26:33.810838197 -0400
+++ gcr-3.20.0/gcr/test-gnupg-collection.c 2017-06-30 17:25:09.149383067 -0400
@@ -115,6 +115,14 @@
g_object_unref (test->collection);
+ /* remove potential gpg 2.1 extras, ignore any errors. */
+ cmd = g_strdup_printf ("rm -rf %s/*.d", test->directory);
+ system(cmd);
+ g_free(cmd);
+ cmd = g_strdup_printf ("rm -f %s/.gpg-v21-migrated", test->directory);
+ system(cmd);
+ g_free(cmd);
+
cmd = g_strdup_printf ("rm -f %s/*", test->directory);
g_spawn_check_exit_status (system (cmd), &error);
g_assert_no_error (error);
@@ -202,7 +210,7 @@
GcrGnupgKey *key;
_gcr_gnupg_collection_load_async (test->collection, NULL, on_async_ready, test);
- egg_test_wait_until (500);
+ egg_test_wait_until (2500);
g_assert (test->result);
_gcr_gnupg_collection_load_finish (test->collection, test->result, &error);
g_assert_no_error (error);
summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-04-14 | doc: Use "dejavu sans" instead of "Helvetica" or "sans" in dot images....Font-dejavu is (now) an input of fontconfig. Specifying "dejavu sans" makes
generated images reproducible even when other fonts are installed (notably
font-google-noto).
* doc/images/bootstrap-graph.dot,
doc/images/bootstrap-packages.dot,
doc/images/coreutils-bag-graph.dot,
doc/images/coreutils-graph.dot,
doc/images/gcc-core-mesboot0-graph.dot,
doc/images/service-graph.dot,
doc/images/shepherd-graph.dot: Use fontname = "dejavu sans".
* doc/guix.texi (Full-Source Bootstrap): Update gcc-core-mesboot0.dot recipe
accordingly.
Change-Id: If21d7d39d45c66de5bceafb7b825a057d540ee50
| Janneke Nieuwenhuizen |
2022-05-12 | doc: Add the "Full-source Bootstrap"....* doc/guix.texi (Reduced Binary Seed Bootstrap): Update and rename to...
(Full-Source Bootstrap): ...this.
* doc/images/gcc-core-mesboot0-graph.dot: Regenerate.
| Jan (janneke) Nieuwenhuizen |
2020-05-22 | doc: Update 'Bootstrapping' for further binary seed reduction....* doc/images/gcc-core-mesboot0-graph.dot: New image, replacing
* doc/images/gcc-mesboot0-bag-graph.dot: ... remove file.
* doc/local.mk (DOT_FILES): Update for new image file.
* doc/guix.texi (Reduced Binary Seed Bootstrap): Use it in updated description
of further reduction of the trusted computing base.
| Jan Nieuwenhuizen |