GCC 4.9 and later have libvtv and, just like libstdc++ (see
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354), it doesn't
have $libdir in its RUNPATH, but it NEEDs libgcc_s. This patch
fixes that.
--- gcc-4.9.2/libvtv/Makefile.in 2014-10-30 09:28:58.000000000 +0100
+++ gcc-4.9.2/libvtv/Makefile.in 2015-04-30 09:51:04.161129705 +0200
@@ -15,6 +15,7 @@
@SET_MAKE@
+AM_LDFLAGS = -Wl,-rpath=$(libdir)
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
alt='cgit logo'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
.gitignore: Ignore .mo files....* .gitignore: Ignore files matching the *.mo pattern.
Maxim Cournoyer |
2021-05-05 | .gitignore: Ignore .tarball-ignore....This file can be useful to fix a version string when experimenting with 'make
release'.
* .gitignore: Add a pattern to ignore .tarball-version.
| Maxim Cournoyer |
2021-04-23 | .gitignore: Ignore release artifacts....Not ignoring these in the tree leads to the next generated version (.version)
being suffixed with '-dirty', which confuses things.
* .gitignore [/guix-*]: New pattern.
[/doc/stamp-[0-9]]: Adjust to ...
[/doc/stamp-*]: ... this.
[/release-*]: New pattern.
| Maxim Cournoyer |
2021-04-23 | .gitignore: Ignore generated .pot files....These files are automatically-extracted templates rather than source, hence
shouldn't be checked in.
* .gitignore: Add a glob pattern to ignore .pot files.
| Maxim Cournoyer |
2020-10-20 | gitignore: Ignore generated guile binary and intermediate products....* .gitignore: Ignore guile, guile-guile-launcher.o, .deps and .dirstamp.
| Julien Lepiller |
2020-09-17 | guix-install.sh: Support OpenRC....* etc/guix-install.sh (chk_init_sys): Detect OpenRC.
(sys_enable_guix_daemon): Install & enable the Guix daemon on such
systems.
* etc/openrc/guix-daemon.in: New file.
* nix/local.mk: Add a rule for it.
(openrcservicedir, nodist_openrcservice_DATA): New variables.
(CLEANFILES, EXTRA_DIST): Add them.
* .gitignore: Ignore etc/openrc/guix-daemon.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
| Morgan Smith |