GCC 4.9 and later have libvtv and, just like libstdc++ (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354), it doesn't have $libdir in its RUNPATH, but it NEEDs libgcc_s. This patch fixes that. --- gcc-4.9.2/libvtv/Makefile.in 2014-10-30 09:28:58.000000000 +0100 +++ gcc-4.9.2/libvtv/Makefile.in 2015-04-30 09:51:04.161129705 +0200 @@ -15,6 +15,7 @@ @SET_MAKE@ +AM_LDFLAGS = -Wl,-rpath=$(libdir) VPATH = @srcdir@ pkgdatadir = $(datadir)/@PACKAGE@ .png' alt='cgit logo'/> index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/build-utils.scm
AgeCommit message (Expand)Author
2020-11-16Properly deal with build directories containing '~'....Fixes <https://bugs.gnu.org/44626>. Reported by Vagrant Cascadian <vagrant@debian.org>. * tests/build-utils.scm ("wrap-script, simple case"): Pass SCRIPT-CONTENTS to 'display' rather than 'format'. * gnu/services/base.scm (file-system->shepherd-service-name) [valid-characters, mount-point]: New variables. Filter out invalid store file name characters from the mount point of FILE-SYSTEM. Ludovic Courtès
2019-11-26tests: Avoid unnecessary use of 'mock'....* tests/build-utils.scm ("wrap-script, simple case"): Use the real 'which' instead of mocking it. Ludovic Courtès
2019-11-26tests: Avoid (catch 'srfi-34 …) form....* tests/build-utils.scm ("wrap-script, raises condition"): Use 'guard' instead of "catch 'srfi-34". Ludovic Courtès
2019-06-17utils: Add 'invoke/quiet'....* gnu/build/bootloader.scm (G_): Remove. (open-pipe-with-stderr, invoke/quiet): Move to... * guix/build/utils.scm: ... here. Use 'let-values' instead of 'define-values' because Guile 2.0 (the bootstrap Guile) doesn't know about 'define-values'. * po/guix/POTFILES.in: Remove gnu/build/bootloader.scm, and add guix/build/utils.scm. * tests/build-utils.scm: Remove import of (gnu build bootloader). Ludovic Courtès
2019-03-23Merge branch 'staging' into core-updatesMarius Bakke
2019-03-16booloader: Add 'invoke/quiet'....* gnu/build/bootloader.scm (G_): New macro. (open-pipe-with-stderr, invoke/quiet): New procedures. * tests/build-utils.scm ("invoke/quiet, success") ("invoke/quiet, failure") ("invoke/quiet, failure, message on stderr"): New tests. * po/guix/POTFILES.in: Add bootloader.scm. Ludovic Courtès
2019-03-16tests: Add 'with-environment-variable'....* tests/scripts.scm (with-environment-variable): Move to... * guix/tests.scm (with-environment-variable): ... here. * tests/build-utils.scm ("wrap-program, one input, multiple calls"): Use it instead of 'setenv'. Ludovic Courtès
2019-02-08guix: Add wrap-script....* guix/build/utils.scm (wrap-script): New procedure. (&wrap-error): New condition. (wrap-error?, wrap-error-program, wrap-error-type): New procedures. * tests/build-utils.scm ("wrap-script, simple case", "wrap-script, with encoding declaration", "wrap-script, raises condition"): New tests. Ricardo Wurmus