Remove use of deprecated ustat interface in glibc 2.28: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85835 Taken from upstream: https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=260684 diff --git a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc index 858bb2184505..de18e56d11cf 100644 --- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc +++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc @@ -157,7 +157,6 @@ typedef struct user_fpregs elf_fpregset_t; # include #endif #include -#include #include #include #include @@ -250,7 +249,19 @@ namespace __sanitizer { #endif // SANITIZER_LINUX || SANITIZER_FREEBSD #if SANITIZER_LINUX && !SANITIZER_ANDROID - unsigned struct_ustat_sz = sizeof(struct ustat); + // Use pre-computed size of struct ustat to avoid which + // has been removed from glibc 2.28. +#if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \ + || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \ + || defined(__x86_64__) +#define SIZEOF_STRUCT_USTAT 32 +#elif defined(__arm__) || defined(__i386__) || defined(__mips__) \ + || defined(__powerpc__) || defined(__s390__) +#define SIZEOF_STRUCT_USTAT 20 +#else +#error Unknown size of struct ustat +#endif + unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT; unsigned struct_rlimit64_sz = sizeof(struct rlimit64); unsigned struct_statvfs64_sz = sizeof(struct statvfs64); #endif // SANITIZER_LINUX && !SANITIZER_ANDROID option value='author'>author
AgeCommit message (Expand)Author
2020-04-14nls: Update.Ludovic Courtès
2020-04-12nls: Update.Ludovic Courtès
2020-03-23nls: Update.Ludovic Courtès
2019-05-13nls: Update 'fr' translation.Julien Lepiller
2019-05-03nls: Update da translations.Ludovic Courtès
2019-05-01nls: Update translations for de and fr.Ludovic Courtès
2019-04-25nls: Update 'es' translation.Julien Lepiller
2019-04-25nls: Update 'fr' translation.Julien Lepiller
2019-04-13nls: Update 'fr' translation.Julien Lepiller