This patch was taken from the official GCC git repository.
X-Git-Url: https://gcc.gnu.org/git/?p=gcc.git;a=blobdiff_plain;f=contrib%2Ftexi2pod.pl;h=91bdbb5cea933d0381f2924ab94490fca31d5800;hp=eba1bcaa3cffa78b46030b219d04fe7d68367658;hb=67b56c905078d49d3e4028085e5cb1e1fb87a8aa;hpb=2f508a78310caab123e9794d3dcfe41f2769449b
It fixes a defect in the contrib/texi2pod.pl script that prevented generating
manual pages. It was corrected in the GCC 6.X series.
diff --git a/contrib/texi2pod.pl b/contrib/texi2pod.pl
index eba1bca..91bdbb5 100755
--- a/contrib/texi2pod.pl
+++ b/contrib/texi2pod.pl
@@ -316,7 +316,7 @@ while(<$inf>) {
@columns = ();
for $column (split (/\s*\@tab\s*/, $1)) {
# @strong{...} is used a @headitem work-alike
- $column =~ s/^\@strong{(.*)}$/$1/;
+ $column =~ s/^\@strong\{(.*)\}$/$1/;
push @columns, $column;
}
$_ = "\n=item ".join (" : ", @columns)."\n";
'>Wojtek's customized Guix
|
Age | Commit message (Expand) | Author |
2023-10-22 | gnu: patman: Apply patch for new Change-Id setting....* gnu/packages/bootloaders.scm (u-boot) [source]: Apply patch.
* gnu/packages/patches/u-boot-patman-change-id.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* .patman (keep_change_id): Use it.
Series-changes: 3
- New commit
Change-Id: I33c03013f6a260b5f5d80212b7b6ebe8a3f97efa
| Maxim Cournoyer |
2023-05-01 | .patman: Remove get_maintainer_script option....This is now handled at the level of git via its new '--header-cmd' option,
which produces X-Debbugs-CC headers.
* .patman (get_maintainer_script): Delete option.
| Maxim Cournoyer |
2023-02-25 | .patman: Ignore bad tags....The feature is not used in Guix, and it produces extraneous warnings.
* .patman (ignore_bad_tags): Set option to True.
| Maxim Cournoyer |
2022-12-28 | .patman: New configuration file....* .patman: New file.
Series-to: 60218@debbugs.gnu.org
Series-cc: rekado@elephly.net, othacehe@gnu.org
Series-version: 2
| Maxim Cournoyer |