This fixes ../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc: In function ‘void* __gnu_cxx::aligned_alloc(std::size_t, std::size_t)’: ../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc:78:10: error: ‘memalign’ was not declared in this scope return memalign (al, sz); ^~~~~~~~ ../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc:78:10: note: suggested alternative: ‘max_align_t’ return memalign (al, sz); ^~~~~~~~ max_align_t diff --git a/libstdc++-v3/libsupc++/new_opa.cc b/libstdc++-v3/libsupc++/new_opa.cc index 94e79cadb0e..084900e0daf 100644 --- a/libstdc++-v3/libsupc++/new_opa.cc +++ b/libstdc++-v3/libsupc++/new_opa.cc @@ -39,6 +39,8 @@ extern "C" void *memalign(std::size_t boundary, std::size_t size); # endif #endif +#define memalign _aligned_malloc + using std::new_handler; using std::bad_alloc; 'switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system.scm
AgeCommit message (Expand)Author
2016-10-30system: Record store file system info in each generation....Chris Marusich
2016-09-30Merge branch 'master' into core-updatesLudovic Courtès
2016-09-24system: grub.cfg uses correct file names when store is not in root partition....Carlos Sánchez de La Lama
2016-09-24system: 'read-boot-parameters' reads the 'initrd' parameter....Ludovic Courtès
2016-09-10system: Use 'file-append' to denote file names....Ludovic Courtès
2016-09-09system: Build the initrd file name with 'file-append'....Ludovic Courtès
2016-09-09system: grub: Allow arbitrary kernel file names in 'menu-entry'....Ludovic Courtès
2016-08-29Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner
2016-08-22services: Make a single extensible 'file-systems' service....Ludovic Courtès
2016-08-10gnu: glibc/linux: Adjust variable name to upstream change....Leo Famulari
2016-08-02system: Define 'GUIX_LOCPATH' to work around 'glibc' package defect....Ludovic Courtès