This fixes ../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc: In function ‘void* __gnu_cxx::aligned_alloc(std::size_t, std::size_t)’: ../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc:78:10: error: ‘memalign’ was not declared in this scope return memalign (al, sz); ^~~~~~~~ ../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc:78:10: note: suggested alternative: ‘max_align_t’ return memalign (al, sz); ^~~~~~~~ max_align_t diff --git a/libstdc++-v3/libsupc++/new_opa.cc b/libstdc++-v3/libsupc++/new_opa.cc index 94e79cadb0e..084900e0daf 100644 --- a/libstdc++-v3/libsupc++/new_opa.cc +++ b/libstdc++-v3/libsupc++/new_opa.cc @@ -39,6 +39,8 @@ extern "C" void *memalign(std::size_t boundary, std::size_t size); # endif #endif +#define memalign _aligned_malloc + using std::new_handler; using std::bad_alloc; tch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services.scm
AgeCommit message (Expand)Author
2022-08-30services: provenance: Use 'current-channels' to obtain provenance data....Ludovic Courtès
2022-05-29gnu: services: Update setuid service description....Tobias Geerinckx-Rice
2022-05-18services: Make <service-type> 'description' field mandatory....Ludovic Courtès
2022-05-18services: Add more description fields....Ludovic Courtès
2022-03-10services: startup: Add description....Ludovic Courtès
2021-11-27services: Document the 'delete' clause of 'modify-services'....Ludovic Courtès
2021-08-12system: Handle 'setuid-programs' deprecation handling as a field sanitizer....Ludovic Courtès
2021-07-29services: setuid: More configurable setuid support....Chris Lemmer-Webber
2021-05-11gnu: Allow services to install kernel-loadable modules....raid5atemyhomework