Search path environment variables for cross-compilers. See the discussion at . Note: Touch 'C_INCLUDE_PATH' et al. rather than 'CPATH', as discussed at . --- a/gcc/incpath.c +++ b/gcc/incpath.c @@ -461,8 +461,8 @@ register_include_chains (cpp_reader *pfile, const char *sysroot, int stdinc, int cxx_stdinc, int verbose) { static const char *const lang_env_vars[] = - { "C_INCLUDE_PATH", "CPLUS_INCLUDE_PATH", - "OBJC_INCLUDE_PATH", "OBJCPLUS_INCLUDE_PATH" }; + { "CROSS_C_INCLUDE_PATH", "CROSS_CPLUS_INCLUDE_PATH", + "CROSS_OBJC_INCLUDE_PATH", "CROSS_OBJCPLUS_INCLUDE_PATH" }; cpp_options *cpp_opts = cpp_get_options (pfile); size_t idx = (cpp_opts->objc ? 2: 0); @@ -473,7 +473,7 @@ register_include_chains (cpp_reader *pfile, const char *sysroot, /* CPATH and language-dependent environment variables may add to the include chain. */ - add_env_var_paths ("CPATH", BRACKET); + add_env_var_paths ("CROSS_CPATH", BRACKET); add_env_var_paths (lang_env_vars[idx], SYSTEM); target_c_incpath.extra_pre_includes (sysroot, iprefix, stdinc); diff --git a/gcc/system.h b/gcc/system.h index 42bc509..af3b9ad 100644 --- a/gcc/system.h +++ b/gcc/system.h @@ -1063,4 +1063,6 @@ helper_const_non_const_cast (const char *p) /* Get definitions of HOST_WIDE_INT and HOST_WIDEST_INT. */ #include "hwint.h" +#define LIBRARY_PATH_ENV "CROSS_LIBRARY_PATH" + #endif /* ! GCC_SYSTEM_H */ diff --git a/gcc/tlink.c b/gcc/tlink.c index bc358b8..ad6242f 100644 --- a/gcc/tlink.c +++ b/gcc/tlink.c @@ -458,7 +458,7 @@ recompile_files (void) file *f; putenv (xstrdup ("COMPILER_PATH=")); - putenv (xstrdup ("LIBRARY_PATH=")); + putenv (xstrdup (LIBRARY_PATH_ENV "=")); while ((f = file_pop ()) != NULL) { diff --git a/gcc/gcc.c b/gcc/gcc.c index 0f042b0..c23fb0b 100644 --- a/gcc/gcc.c +++ b/gcc/gcc.c @@ -4264,7 +4264,7 @@ process_command (unsigned int decoded_options_count, } temp = env.get (LIBRARY_PATH_ENV); - if (temp && *cross_compile == '0') + if (temp) { const char *startp, *endp; char *nstore = (char *) alloca (strlen (temp) + 3); 882f5b4309f77c3dc3e65559d7b7cb75'>packages/photo.scm
AgeCommit message (Expand)Author
2018-11-05gnu: libgphoto2: Update to 2.5.20....Marius Bakke
2018-11-03gnu: perl-image-exiftool: Update to 11.11....Ludovic Courtès
2018-10-21gnu: libgphoto2: Update to 2.5.19....Marius Bakke
2018-09-01gnu: Krita: Build with libraw 0.18....Leo Famulari
2018-08-27gnu: libexif: Update home-page URL....Leo Famulari
2018-08-11Migrate search.cpan.org home pages to metacpan.org....Tobias Geerinckx-Rice
2018-07-15gnu: libraw: Use libjpeg@9....Efraim Flashner
2018-07-01gnu: libraw: Enable optional functionality....Marius Bakke
2018-07-01gnu: libraw: Correct license....Marius Bakke
2018-07-01gnu: libraw: Update to 0.19.0....Marius Bakke
2018-06-30gnu: libgphoto2: Update to 2.5.18....Tobias Geerinckx-Rice
2018-06-28gnu: perl-image-exiftool: Update to 11.01....Leo Famulari
2018-06-11gnu: libraw: Update to 0.18.12 [security fixes]....Marius Bakke
2018-06-06gnu: darktable: Update to 2.4.4....Leo Famulari
2018-05-17gnu: libraw: Update to 0.18.11....