GCC 4.9 and later have libvtv and, just like libstdc++ (see
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354), it doesn't
have $libdir in its RUNPATH, but it NEEDs libgcc_s. This patch
fixes that.
--- gcc-5.1.0/libvtv/Makefile.in 2014-10-30 09:28:58.000000000 +0100
+++ gcc-5.1.0/libvtv/Makefile.in 2015-04-30 09:51:04.161129705 +0200
@@ -15,6 +15,7 @@
@SET_MAKE@
+libvtv_la_LDFLAGS = -Wl,-rpath=$(libdir)
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
='cgit logo'/>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-01-30 | services: getmail: Fix spelling of "address"....* gnu/services/getmail (getmail-retriever-configuration): Fix typo.
| Vagrant Cascadian |
2020-01-20 | services: getmail: Adjust a couple of default configuration values....Change the message-log-syslog and message-log-verbose configuration values to
match the Getmail defaults.
* gnu/services/getmail.scm (getmail-options-configuration): Change defaults
for message-log-syslog and message-log-verbose
* doc/guix.texi (Mail Services): Update the Getmail documentation accordingly.
| Christopher Baines |
2020-01-20 | services: getmail: Fix some configuration documentation strings....* gnu/services/getmail.scm (getmail-retriever-configuration): Specify proper
documentation strings for some of the fields.
* doc/guix.texi (Mail Services): Update the documentation accordingly.
| Christopher Baines |
2020-01-20 | services: getmail: Fix stopping the shepherd service....* gnu/services/getmail.scm (getmail-shepherd-services): Add a stop component
to the shepherd services.
| Christopher Baines |
2019-10-18 | Fix documentation of delete_after in the getmail service....* doc/guix.texi (Getmail service): Remove the word `not'.
* gnu/services/getmail.scm (getmail-options-configuration): Ditto.
| Florian Pelz |
2019-05-31 | services: Add getmail....Getmail is a mail retriever written in Python, this commit adds a service-type
to run getmail. I'm looking at this, as it's a convinient way of getting
mailing list messages in to Patchwork.
I initially tried putting this in the (gnu services mail) module, but due to
also trying to use the define-configuration pattern, it conflicted with the
dovecot service.
* gnu/services/getmail.scm: New file.
* gnu/local.mk: Add it.
* gnu/tests/mail.scm (%getmail-os, %test-getmail): New variables.
(run-getmail-test): New procedure.
| Christopher Baines |