GCC 4.9 and later have libvtv and, just like libstdc++ (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354), it doesn't have $libdir in its RUNPATH, but it NEEDs libgcc_s. This patch fixes that. --- gcc-5.1.0/libvtv/Makefile.in 2014-10-30 09:28:58.000000000 +0100 +++ gcc-5.1.0/libvtv/Makefile.in 2015-04-30 09:51:04.161129705 +0200 @@ -15,6 +15,7 @@ @SET_MAKE@ +libvtv_la_LDFLAGS = -Wl,-rpath=$(libdir) VPATH = @srcdir@ pkgdatadir = $(datadir)/@PACKAGE@ index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d4160b6a7f..bf21497997 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49,6 +49,28 @@ support.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-bencher
+ (package
+ (name "rust-bencher")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bencher" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1x8p2xblgqssay8cdykp5pkfc0np0jk5bs5cx4f5av097aav9zbx"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/bluss/bencher/")
+ (synopsis "Port of the libtest benchmark runner to Rust stable")
+ (description "This package provides a port of the libtest (unstable Rust)
+benchmark runner to Rust stable releases. Supports running benchmarks and
+filtering based on the name. Benchmark execution works exactly the same way
+and no more (caveat: black_box is still missing!).")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-proc-macro2
(package
(name "rust-proc-macro2")