--- a/libgcc/config/i386/gthr-win32.h 2016-03-30 07:45:33.388684463 +0200
+++ b/libgcc/config/i386/gthr-win32.h 2016-03-30 15:51:24.123896436 +0200
@@ -30,7 +30,7 @@
/* Make sure CONST_CAST2 (origin in system.h) is declared. */
#ifndef CONST_CAST2
-#define CONST_CAST2(TOTYPE,FROMTYPE,X) ((__extension__(union {FROMTYPE _q; TOTYPE _nq;})(X))._nq)
+#define CONST_CAST2(TOTYPE,FROMTYPE,X) ((TOTYPE)X)
#endif
/* Windows32 threads specific definitions. The windows32 threading model
s='main'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-06-11 | system: Align zram priority with swap-space spec to clarify....Fixes <https://issues.guix.gnu.org/54783>.
* gnu/services/linux.scm (zram-device-configuration)
[priority]: Adapt to use #f or an integer from 0 to 32767. Add sanitizer to
warn for the change and delay the field.
(zram-device-configuration->udev-string): Adapt as above.
* doc/guix.texi (Zram Device Service): Remove double copyright line.
Change priority description to refer to the Swap Space one, and suggest not
leaving the default #f on to properly use zram.
Reported-by: Stefan Baums <baums@stefanbaums.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Josselin Poiret |