Remove use of deprecated ustat interface in glibc 2.28: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85835 Adapted to GCC 4 series from this upstream patch: https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=260684 --- a/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc +++ b/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc @@ -81,7 +81,6 @@ #include #include #include -#include #include #include #include @@ -163,7 +162,19 @@ unsigned struct_old_utsname_sz = sizeof(struct old_utsname); unsigned struct_oldold_utsname_sz = sizeof(struct oldold_utsname); unsigned struct_itimerspec_sz = sizeof(struct itimerspec); - unsigned struct_ustat_sz = sizeof(struct ustat); + // Use pre-computed size of struct ustat to avoid which + // has been removed from glibc 2.28. +#if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \ + || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \ + || defined(__x86_64__) +#define SIZEOF_STRUCT_USTAT 32 +#elif defined(__arm__) || defined(__i386__) || defined(__mips__) \ + || defined(__powerpc__) || defined(__s390__) +#define SIZEOF_STRUCT_USTAT 20 +#else +#error Unknown size of struct ustat +#endif + unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT; #endif // SANITIZER_LINUX #if SANITIZER_LINUX && !SANITIZER_ANDROID n.scm?id=34867ac9cf0d5a882b3a70223df51c7317b3737d'>diff
AgeCommit message (Expand)Author
2022-10-27gnu: swftools: Fix typos....Vagrant Cascadian
2022-10-23gnu: Fix typos....Vagrant Cascadian
2022-08-30gnu: Add swftools....Tomasz Jeneralczyk
2022-08-21gnu: lightspark: Remove input labels....Vinicius Monego
2022-08-21gnu: lightspark: Update to 0.8.6....Vinicius Monego
2022-08-21gnu: lightspark: Remove optional input gnash....Vinicius Monego
2022-07-31gnu: qttools: Rename to qttools-5....Maxim Cournoyer
2022-07-31gnu: qtmultimedia: Rename to qtmultimedia-5....Maxim Cournoyer
2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....Maxim Cournoyer