This is a backport of part of this patch from 6.5 to 4.8: https://gcc.gnu.org/git/?p=gcc.git;a=patch;h=8937b94d1a643fd9760714642296d034a45254a8 --- a/libsanitizer/tsan/tsan_platform_linux.cc +++ b/libsanitizer/tsan/tsan_platform_linux.cc @@ -351,7 +351,7 @@ bool IsGlobalVar(uptr addr) { // closes within glibc. The code is a pure hack. int ExtractResolvFDs(void *state, int *fds, int nfd) { int cnt = 0; - __res_state *statp = (__res_state*)state; + struct __res_state *statp = (struct __res_state*)state; for (int i = 0; i < MAXNS && cnt < nfd; i++) { if (statp->_u._ext.nsaddrs[i] && statp->_u._ext.nssocks[i] != -1) fds[cnt++] = statp->_u._ext.nssocks[i]; Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix
AgeCommit message (Expand)Author
2019-11-29daemon: 'pathExists' uses 'statx' when available....Ludovic Courtès
2019-11-27daemon: 'deletePath' uses 'statx' when available....Ludovic Courtès
2019-11-27daemon: GC remove-unused-links phase uses 'statx' when available....Ludovic Courtès
2019-11-26daemon: boost::format: Fix typo "referred"....Vagrant Cascadian
2019-11-26guix build, daemon: Rename "--no-build-hook" to "--no-offload"....Ludovic Courtès
2019-11-22daemon: GC displays how much it has collected....Ludovic Courtès
2019-11-13daemon: Don't include <linux/fs.h>....Ludovic Courtès
2019-11-04daemon: Unregister build hook from the worker's children upon build failure....Ludovic Courtès
2019-10-16daemon: Make 'profiles/per-user' non-world-writable....Ludovic Courtès
2019-10-16daemon: Remove traces of 'NIX_ROOT_FINDER'....Ludovic Courtès
2019-09-28daemon: Strictly respect timeouts for 'guix offload'....Ludovic Courtès
2019-09-16daemon: Include 'config.h' in 'nix-daemon.cc'....Timothy Sample