From f0065f207cf19cd960b33d961472c6d69514336f Mon Sep 17 00:00:00 2001 From: Samuel Thibault Date: Fri, 7 Oct 2022 22:45:06 +0200 Subject: [PATCH] libstdc++: Mark pieces of gnu-linux/os_support.h linux-specific This is notably needed because in glibc 2.34, the move of pthread functions into libc.so happened for Linux only, not GNU/Hurd. The pthread_self() function can also always be used fine as it is on GNU/Hurd. libstdc++-v3/ChangeLog: * config/os/gnu-linux/os_defines.h [!__linux__] (_GLIBCXX_NATIVE_THREAD_ID, _GLIBCXX_GTHREAD_USE_WEAK): Do not define. Reviewed-by: Jonathan Wakely --- libstdc++-v3/config/os/gnu-linux/os_defines.h | 22 +++++++++++-------- 1 file changed, 13 insertions(+), 9 deletions(-) diff --git a/libstdc++-v3/config/os/gnu-linux/os_defines.h b/libstdc++-v3/config/os/gnu-linux/os_defines.h index 3064f8d908ac2..87317031fcd71 100644 --- a/libstdc++-v3/config/os/gnu-linux/os_defines.h +++ b/libstdc++-v3/config/os/gnu-linux/os_defines.h @@ -60,22 +60,26 @@ # define _GLIBCXX_HAVE_FLOAT128_MATH 1 #endif -#if __GLIBC_PREREQ(2, 27) +#ifdef __linux__ +// The following libpthread properties only apply to Linux, not GNU/Hurd. + +# if __GLIBC_PREREQ(2, 27) // Since glibc 2.27 pthread_self() is usable without linking to libpthread. -# define _GLIBCXX_NATIVE_THREAD_ID pthread_self() -#else +# define _GLIBCXX_NATIVE_THREAD_ID pthread_self() +# else // Before then it was in libc.so.6 but not libc.a, and always returns 0, // which breaks the invariant this_thread::get_id() != thread::id{}. // So only use it if we know the libpthread version is available. // Otherwise use (__gthread_t)1 as the ID of the main (and only) thread. -# define _GLIBCXX_NATIVE_THREAD_ID \ - (__gthread_active_p() ? __gthread_self() : (__gthread_t)1) -#endif +# define _GLIBCXX_NATIVE_THREAD_ID \ + (__gthread_active_p() ? __gthread_self() : (__gthread_t)1) +# endif -#if __GLIBC_PREREQ(2, 34) +# if __GLIBC_PREREQ(2, 34) // Since glibc 2.34 all pthreads functions are usable without linking to // libpthread. -# define _GLIBCXX_GTHREAD_USE_WEAK 0 -#endif +# define _GLIBCXX_GTHREAD_USE_WEAK 0 +# endif +#endif // __linux__ #endif p;showmsg=1'>root/gnu/packages/rdesktop.scm
AgeCommit message (Collapse)Author
2024-07-11gnu: xrdp: update to 0.10.0.Andy Tai
* gnu/packages/rdesktop.scm (xrdp): Update to 0.10.0. [native-inputs]: Add cmocka. Change-Id: Ifdf6e8759753d49a8f169aac128a943be71f2958 Signed-off-by: jgart <jgart@dismail.de>
2024-04-26gnu: freerdp: Update to 2.11.7.Andy Tai
* gnu/packages/rdesktop.scm (freerdp): Update to 2.11.7. Change-Id: I41385d4db719e950438c07d2149c845ee28cabce Signed-off-by: Christopher Baines <mail@cbaines.net>
2023-12-07gnu: xrdp: Update to 0.9.23.1.Andy Tai
* gnu/packages/rdesktop.scm (xrdp): Update to 0.9.23.1. Change-Id: If5a01e38dc04bd013118d21ff11a46f3e7dddfd2 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
2023-10-04gnu: freerdp: Update to 2.11.2.Timotej Lazar
* gnu/packages/rdesktop.scm (freerdp): Update to 2.11.2. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
2023-09-25gnu: freerdp: Update to 2.11.1.Timotej Lazar
* gnu/packages/rdesktop.scm (freerdp): Update to 2.11.1. [inputs]: Add pcsc-lite. Signed-off-by: Christopher Baines <mail@cbaines.net>
2023-09-04gnu: freerdp: Enable server build.Andy Tai
* gnu/packages/rdesktop.scm (freerdp): Enable server build. [phases] (configure-flags): Enable server build flags. [inputs]: Add server build dependencies and additional protocols cairo, dbus, gsm, lame, libxdamage, opencl, openh264, openssl. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
2023-08-12gnu: Add xorgxrdp.Andy Tai
* gnu/packages/rdesktop.scm (xorgxrdp): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-08-12gnu: Add xrdp.Andy Tai
* gnu/packages/rdesktop.scm (xrdp): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>